Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Authorization or Token retrieval in getHeader request

adithyacs86
Level 5
Level 5

Hi Team, 

 

We are trying to pull the authorization data that we are sending as a header in postman and the endpoint URL is AC jssp link (which is dynamic server page). 

adithyacs86_0-1620312962682.png

this JSSP page we have created in Adobe campaign.

But not able to request this header parameter from the request.getHeader. 

adithyacs86_1-1620313046380.png

 

Rather we are able to get the data for the Accept-Language which we have given as EN as shown above in postman through the getRequest in Adobe Campaign. 

 

Requesting for an help in here on how can we request the authorization field as a request but not as a response. 

 

Thanks,
Adithya

 

Adobe Campaign Classic
1 Accepted Solution
adithyacs86
Correct answer by
Level 5
Level 5
Hi, Yes we are able to resolve the issue, but as a work around, instead of using Authorization or token ; we have used the cookies to get the Authorization, which is working now.

View solution in original post

11 Replies
Manoj_Kumar_
Community Advisor
Community Advisor

Hello @adithyacs86 

 

Can you share the postman field screenshot?

adithyacs86
Level 5
Level 5
Hi Manoj, I have already posted both Postman and the AC logInfo we are trying to retrieve in the initial post.
Manoj_Kumar_
Community Advisor
Community Advisor
Can you try changing it to AutorizationTest and get the value? If that works then may be Authorization header is blocked on JSSP pages.
adithyacs86
Level 5
Level 5

Hi Manoj, we tried like this :-

 

adithyacs86_0-1620365675531.png

 

But as you can see the log from AC "Authorization" is not showing up any data.

CRey_Axa
Level 1
Level 1
Hello adithaycs, I think this is due to the web server configuration. It seems related to this post : https://experienceleaguecommunities.adobe.com/t5/adobe-campaign-classic/iis-not-forwarding-any-heade... I tried your request and get the same result. But if I request directly the Tomcat it works. Can you try to request your server on the 8080 port and without secure https ? (=> http://yourserver-domain:8080/xxx/yourjssppage.jssp)
adithyacs86
Level 5
Level 5

Hi ,

 

Thanks for the inputs and yes we tried the same but the URL is timing out and not hitting the server. 

 

adithyacs86_0-1620380657305.png

 

 

But with https we are not getting Authorization but we are able to fetch details for Accept-Language. 

adithyacs86_1-1620380743054.png

 

Thanks,
Adithya

SachinDhir
Level 2
Level 2
Facing the same issue.... unable to fecth any custom header on request object??
wodnicki
Community Advisor
Community Advisor

Hi,

 

It's being filtered out by your web server, either Apache or IIS.

You can verify this by visiting Tomcat directly over port 8080.

New versions of Apache have a conf directive called CGIPassAuth, though I haven't had any luck with it.

 

Thanks,

-Jon

Sukrity_Wadhwa
Employee
Employee

Hi @adithyacs86,

Were you able to resolve this query with any of the given solutions or do you still need more help here? Do let us know.

Thanks!

adithyacs86
Correct answer by
Level 5
Level 5
Hi, Yes we are able to resolve the issue, but as a work around, instead of using Authorization or token ; we have used the cookies to get the Authorization, which is working now.

View solution in original post