Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Unspecified Values for Evars

ioamaf
Level 2
Level 2

Hello,

Recently I have added tracking to a new form implemented on my website. Basically there are a couple of options the user can select: model for a product, range, owner type etc. I have created separate evars for these options, each of them is being set up via a Direct Call Rule, with the information taken from the data layer.

I have tested the Adobe Analytics calls with the available debuggers for both DTM and AA all looks clean and correct. However, when checking the data I get a lot of unspecified values for these options submitted. The tot number for all options is the same (equal to form completions).

I have taken the form in a preprod environment and tested it there to compare the values submitted to the ones displayed in AA : the calls in the console looked fine, the unspecified values have no specific pattern... (checked devices/ broswer).

So right now I don't know exactly where I should be looking and investigating further. Has any of you gone through a similar issue? If so any help is much appreciated.

Thank you,

Ioana

1 Accepted Solution
karandeeps51149
Correct answer by
Employee
Employee

Hi Loana,

You can see unspecified in an evar report. It depends which metric you are using in an evar report. Below is the document that will explain in detail about unspecified.

None, Unspecified, Unknown, and Other in reporting

However, if you are trying to check how many time that evar fired. I will suggest you to please use Instances metric. As instances will show you number of times the evar fired and will not show unspecified.

Regards

Karandeep Singh

View solution in original post

4 Replies
karandeeps51149
Correct answer by
Employee
Employee

Hi Loana,

You can see unspecified in an evar report. It depends which metric you are using in an evar report. Below is the document that will explain in detail about unspecified.

None, Unspecified, Unknown, and Other in reporting

However, if you are trying to check how many time that evar fired. I will suggest you to please use Instances metric. As instances will show you number of times the evar fired and will not show unspecified.

Regards

Karandeep Singh

View solution in original post

ioamaf
Level 2
Level 2

Hi Karandeep,

I took you advice and used the instances instead. It seem like a great solution so far. However the number of forms completed does not match the total number of Instances... Any idea why that could be happening? Not a huge difference between the 2 but we still have to justify it.

LE: the number of instances is higher.

Thanks for the help, I finally got a new path to explore as I was really stuck.

Best regards,

Ioana M.

ursboller
Community Advisor
Community Advisor

did you try to figure out if there is a problem with tracking for users having a certain browser/device? might be  that the rules don't fire on certain browser/devices or when using "tab"/"enter"... in the form...

ioamaf
Level 2
Level 2

Hey,

Thanks for the suggestion! I have previously tested that and everything is fine. I think I have found the problem... It occurs when the users submits the form and then clicks on the 'back' browser button and then submits again.. the completion event fires only the first time.

Thanks all for taking time and replying!

Cheers,

Ioana