Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Unspecified Data In Adobe Analytics

roshanc44331495
Level 4
Level 4

Hi,

I have implemented the custom tracking through DTM but in Adobe Analytics 80% data is Unspecified while checking in debugging mode it's showing the accurate data is being passed to the AA.

What changes I need to make in tracking code?

P.S. I have implemented the events through SC tool >> Customize Page Code > Editor.

1521961_pastedImage_0.png

Thanks!

Roshan

1 Accepted Solution
nickh86417692
Correct answer by
Level 5
Level 5

This looks correct. Our internal search terms report looks very similar. This just means that of all the occurrences on your site (which is pretty much every page view and hit combined) a decent percentage of them happened before anything had been searched. In addition to recording internal search terms, are you setting a custom event when the internal search term is recorded? I would use that event instead of occurrences in this report. As long as there is an internal search term for each time that you record the internal search term, everything looks correct.

For your "support flow step", this means that roughly 75% (I'm just guessing) of your occurrences don't happen in the support flow. So for these users, the majority of their occurrences are on the home page, or search page, or other pages where you aren't specifying the support flow step.

View solution in original post

4 Replies
nickh86417692
Level 5
Level 5

When you say "unspecified", what are you referring to? Are you looking at the pages report and 80% of page views have an unspecified pagename? Or 80% of unique visitors have an unspecified mobile device? In many cases, high levels of unspecified values in a report is normal.

roshanc44331495
Level 4
Level 4

Please look into the below screenshot this, I have implemented the internal site search on the site but it's showing the most of the searches as a Unspecified. When we debug the tracking it's showing data is being passed to the AA.

1522805_pastedImage_0.png

here is another example of Support flow.

1522806_pastedImage_2.png

nickh86417692
Correct answer by
Level 5
Level 5

This looks correct. Our internal search terms report looks very similar. This just means that of all the occurrences on your site (which is pretty much every page view and hit combined) a decent percentage of them happened before anything had been searched. In addition to recording internal search terms, are you setting a custom event when the internal search term is recorded? I would use that event instead of occurrences in this report. As long as there is an internal search term for each time that you record the internal search term, everything looks correct.

For your "support flow step", this means that roughly 75% (I'm just guessing) of your occurrences don't happen in the support flow. So for these users, the majority of their occurrences are on the home page, or search page, or other pages where you aren't specifying the support flow step.

View solution in original post

Austin_M_Smith
Level 1
Level 1
Nick I think you hit the nail on the head with this response,