Expand my Community achievements bar.

Announcement: Calling all learners and mentors! Applications are now open for the Adobe Analytics 2024 Mentorship Program! Come learn from the best to prepare for an official certification in Adobe Analytics.
SOLVED

tracking code not working

Avatar

Level 1

Sandy_Ptarmigan_0-1678105998724.png

Hello,

Anyone experienced this as the tracking code is broken and the campaign cannot be captured by Adobe Analytics and so categorized into unspecified?

 

Thanks!

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Props only have a character limit of 100 characters... 

eVars have a character limit of 255 characters... so it's better to track custom URL into an eVar, but there is still a potential for truncation.

 

How are you setting your eVar11 (campaign name)? If you are setting it in Launch, pulling directly from the query strings and sending that value then you shouldn't have any issues.. but if you are relying on extracting it from other tracking parameters than you could have issues....

 

Here is how I pull my UTM Campaign Value:

Jennifer_Dungan_0-1678132979753.png

 

I still track my Full URL into an eVar, but I don't rely on for my campaigns....

View solution in original post

4 Replies

Avatar

Correct answer by
Community Advisor

Props only have a character limit of 100 characters... 

eVars have a character limit of 255 characters... so it's better to track custom URL into an eVar, but there is still a potential for truncation.

 

How are you setting your eVar11 (campaign name)? If you are setting it in Launch, pulling directly from the query strings and sending that value then you shouldn't have any issues.. but if you are relying on extracting it from other tracking parameters than you could have issues....

 

Here is how I pull my UTM Campaign Value:

Jennifer_Dungan_0-1678132979753.png

 

I still track my Full URL into an eVar, but I don't rely on for my campaigns....

Avatar

Level 1

Hi Jennifer,

 

thanks for replying!

 

I have set the evar into "campaign name", but it captured under "unspecified", or even I pulled evar "traffic source" for utm_source, it shows nothing. The link can only be shown with exit url.

 

Thanks.

Avatar

Community Advisor

Yes, I can see that you have an eVar, but how is that eVar being populated?

 

What you are experiencing looks like an issue with your implementation rather than an issue with Adobe... 

 

I have the same URL truncation in my "Full URL" dimension, but it does not impact my Campaign Name eVar, because I do not rely on parsing the Full URL to populate the data.

 

This is why I asked how your Campaign Name eVar is actually being set.. maybe you need to talk with your implementation specialists / developers.....

 

 

I don't know what you mean by "The link can only be shown with exit url".. . Your exit link values that have UTMs are for the benefit of the site you are linking to... not your own...  unless you are using UTMs for internal links (but then those shouldn't be exit links... so I am really not sure the connection you are suggesting).... just in case you are using UTMs internally, you should really read these:

 

https://www.searchseven.co.uk/blog/why-using-utm-parameters-on-internal-links-is-a-very-bad-idea/

https://www.sammyseo.com/utm-tags-on-internal-links/

https://www.adviso.ca/en/blog/tech-en/never-never-never-tag-internal-link-external-campaign-variable...

 

If you need to track campaigns as part of an internal tracking solution... you should be setting up special Internal Campaign trackers... itm_source, or icid (internal campaign id), etc....

thank you jennifer! will reach out to the implementation team!