Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Segments not visible in Power BI Desktop

Spurthi_Gunadhara
Level 1
Level 1

I have successfully connected Adobe Analytics to my Power BI Desktop. However, I am unable to see my Adobe segments in Power BI. How could I resolve this?

 

1 Accepted Solution
kainth
Correct answer by
Level 5
Level 5

Hi @Spurthi_Gunadhara ,

If you have recently added some new segments that are not appearing Power BI then I would like to inform you that the new segments take some time to appear in the Power BI. However, if none of the segments are appearing in the Power Bi then it seems to be permission related issue. Please make sure that you have the Web Service Access to be able to access the segments & calculated metrics. You can also refer to the below link if that helps.

Link: https://community.powerbi.com/t5/Desktop/Adobe-Analytics-Connector-Unable-to-pull-segments/td-p/8892...

Hope this helps.


Regards,

Abhinav

View solution in original post

10 Replies
absm82288325
Level 1
Level 1

If you are not an Admin, you will need to be added to the Web Services Access group within your implementation in order to see them.  Please see the following Adobe support doc:

 

https://helpx.adobe.com/analytics/kb/integrate-adobe-analytics-with-power-bi.html

 

 

kainth
Correct answer by
Level 5
Level 5

Hi @Spurthi_Gunadhara ,

If you have recently added some new segments that are not appearing Power BI then I would like to inform you that the new segments take some time to appear in the Power BI. However, if none of the segments are appearing in the Power Bi then it seems to be permission related issue. Please make sure that you have the Web Service Access to be able to access the segments & calculated metrics. You can also refer to the below link if that helps.

Link: https://community.powerbi.com/t5/Desktop/Adobe-Analytics-Connector-Unable-to-pull-segments/td-p/8892...

Hope this helps.


Regards,

Abhinav

View solution in original post

Spurthi_Gunadhara
Level 1
Level 1
Hi @kainth, Thanks for the reply. I am not the Admin and hence my Admin has added me to the Web Service Access Group. However, the segments are still not visible. Does it also depend on Power BI version? I am using eth free desktop version.
kainth
Level 5
Level 5

Hi @Spurthi_Gunadhara,

 

Based on my understanding, access to the segments is not dependent on whether you are using a free version of Power BI or a premium version. But, it is dependent on the permissions. As you mentioned that you have the Web Services Access. So, can you please try creating a new segment in Analytics user interface & check after few hours to see if that segment is visible in Power BI? If not then I will suggest you to report this issue to the Client Care team. So, that they can investigate further on this issue if needed.

 

Regards,

Abhinav

Spurthi_Gunadhara
Level 1
Level 1
Thanks Abhinav for your suggestion. I have just created a new segment and shall let you know once I am able to see this one in Power BI.
Spurthi_Gunadhara
Level 1
Level 1
Thanks @MA1985_CG . I cleared my Power BI Cache. However, I am still unable to see the sgements.
jantzen_belliston-Adobe
Community Manager
Community Manager
Do any of the answers below answer your initial question? If so, can you select one of them as the correct answer? If none of the answers already provided answer your question, can you provide additional information to better help the community solve your question?
Vikrantarora25
Level 1
Level 1

Please clear cache in your PBI desktop, all segments will show.