Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Segment building using data objects of digital data layer is not working

Avatar

Level 4

I have web pages which has "Blogs" and "Projects" contentType. Both type of page share the similar url structure for example:

 

Project URL example

https://www.abc.com/s/share/a5U8Y000000bzLQUAY/this-is-a-project-page

Blog URL example

https://www.abc.com/s/share/a5U8Y000000bzLQUAY/this-is-a-blog-page

 

In the digital data layer also they are updated with their corresponding contentType like below. Then Both of the data objects are mapped to a eVars to have the content type captured for reporting.

jsvasu_0-1646154921202.png

jsvasu_1-1646154960691.png

However, when in the analytics I am building the segments using the evar for the contentType dataobject of the page then the analytics numbers goes down for the metrics.  

Screen Shot 2022-03-01 at 11.36.55 AM.pngScreen Shot 2022-03-01 at 11.37.12 AM.png

 

 

This is how the analytics numbers are showing down:

Screen Shot 2022-03-01 at 11.30.04 AM.png

Any suggestions or solutions on that.

Thanks,

JV

 

1 Accepted Solution

Avatar

Correct answer by
Level 2

Okay. My next step here would be to take a common page out of these reports and breakdown it by Content Type report with Unique Visoitors metric. It will show where the discrepancy is.

 

Also, can you please share the definition of the segment "Projects - Content"? 

View solution in original post

7 Replies

Avatar

Level 2

Hi @jsvasu ,

 

Not sure of the cause but I would suggest verifying whether the data layer is consistently populating for the Projects. Maybe the Content Type = projects is not populating consistently and hence causing a reduced no. of Visitors.

Avatar

Level 4

@kaush1889 yes, for every page load the analytics hit is happening and content type is getting captured in the evar.

Avatar

Correct answer by
Level 2

Okay. My next step here would be to take a common page out of these reports and breakdown it by Content Type report with Unique Visoitors metric. It will show where the discrepancy is.

 

Also, can you please share the definition of the segment "Projects - Content"? 

Avatar

Level 4

@kaush1889 I shared this in my first post also. here you see these are 5 common projectcontent type pages. The one on the left side is the table where I am not using the segments and one on the right has the segment project-content (this segment is to pull pages with content type:projects" I am attaching screenshot again to show how the project segment is build

 

Screen Shot 2022-03-01 at 11.30.04 AM.png

 

Screen Shot 2022-03-01 at 11.36.55 AM.png

Avatar

Level 2

In the left report, apply a breakdown by Community - Content Type and share the result.

 

 

 

Avatar

Level 4

why there are so many unspecified? what does that mean?

 

Screen Shot 2022-03-01 at 12.38.03 PM.pngScreen Shot 2022-03-01 at 12.38.17 PM.png

Avatar

Level 2

This is because in actual the values are not being set as I suspected and flagged. Your QA team needs to identify these scenarios to fix it.