Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Report Builder Bug: Excel is waiting for another application to complete an OLE action

alan_millingto1
Level 1
Level 1

Hi All,

In report builder I am continually seeing this error message 4-5 times per day: 'Microsoft Excel is waiting for another application to complete an OLE action'. 
This always gives me an endless loop where I cannot escape the error message and return to editing the data block or Excel. 
The only way to continue is to close Excel is to 'End Task' or kill the Excel process which usually leads to file damage.
The error almost always is generated after making changes to the 'filter' option of a dimension in the request wizard (page 2).

Occasionally, it occurs if the Excel window has been in the background for a short time.

I have tried a number of different setting changes in Excel such as 'Ignore DDE applications' in the advanced settings, but nothing works.

I am using Excel 2010, 32bit, Win7 with Report Builder version 5.2.10 but this bug goes back to at least v4.7. We have tried this in both normal and virtualised installations with the same results. Office 365 is also seeing the same issue (v.5.2.15)

Any ideas would be very much appreciated,
Many Thanks
Alan

1 Accepted Solution
TanmayMathur
Correct answer by
Level 10
Level 10

Hi Alan, 

If you have been experiencing this issue for a long time, it might well be a bug. I would request you to give me step by step details of the RB request you are trying to make (hiding confidential information). I will reproduce it on my end and If the same thing happens I will forward this issue to the engineering for a fix. 

Thanks!

TM

View solution in original post

4 Replies
TanmayMathur
Correct answer by
Level 10
Level 10

Hi Alan, 

If you have been experiencing this issue for a long time, it might well be a bug. I would request you to give me step by step details of the RB request you are trying to make (hiding confidential information). I will reproduce it on my end and If the same thing happens I will forward this issue to the engineering for a fix. 

Thanks!

TM

View solution in original post

pradyut_c
Level 2
Level 2

Hi Alan,

I have been facing this issue for a while now. More often we face this issue if any of the parameters are violated while creating a data block. It should be our first approach to identify if any parameters are being violated by the RB data block.

Thanks

Pradyut

alan_millingto1
Level 1
Level 1

Pradyut Chatterjee wrote...

Hi Alan,

I have been facing this issue for a while now. More often we face this issue if any of the parameters are violated while creating a data block. It should be our first approach to identify if any parameters are being violated by the RB data block.

Thanks

Pradyut

 

I notice this occurs frequently if you have logged in, but not used Report Builder in some time. Then, when you create a data block, the interface 'hangs' when you select to change one of the filter options of the dimensions.

However, if you bring up the sign in screen and log in again, this error message does not seem to happen. So this is the workaround I have been using for several months now (application version 5.2.15)

jamesc82861453
Level 2
Level 2

was there any workaround to this problem. Please share if there is any solution. Thank You