Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Props renaming

prerna
Level 2
Level 2

Hi

So i changed the value of a prop, but all the data (new) is getting attributed to the original value. Any idea why that might be happening or is there any way to bypass this except using processing rules?

1 Accepted Solution
yuhuisg
Correct answer by
Community Advisor
Community Advisor

Have you verified your tag implementation, i.e. to ensure that the new value is indeed being tracked as expected?

View solution in original post

12 Replies
yuhuisg
Community Advisor
Community Advisor

Renaming a prop (or an eVar or success event) won't change the values that are reported, even those values that had been tracked before the renaming.

Are you sure that the prop's name was the only thing that had been changed?

prerna
Level 2
Level 2
I changed the prop's value only (in custom code- s.prop=""); While i understand it would not change existing data attributions, shouldn't new data be attributed to the new value of prop? Even in the reports i see only the old value.
ishans52004352
Employee
Employee

@prerna What is meant by attribution here? If you were passing in s.prop1="prerna" and is now passing s.prop1="prerna1", the prop1 report will show "prerna1" since the time the change was implemented. The report for historical dates will still show "prerna". Likewise when you correlate with another variable.

arindamagarwal
Level 1
Level 1

@ ishans52004352- Ideally, yes, your prop1 reports should now show 'prerna1". Instead, all new instances of prop1 are still showing against 'prerna'. Even the new ones, is this the issue? 

prerna
Level 2
Level 2
Yes. Even after implementing the change, I cannot see the changed prop value in the reports.
yuhuisg
Community Advisor
Community Advisor

@prernawhen you run the report for that changed prop, are you reporting with date ranges that are after you had changed the prop's values?

E.g.

1 April: s.prop = "prerna"

5 April: s.prop = "prerna1"

Report for 1-4 April: only "prerna" is reported.

Report for 5 April: only "prerna1" is reported.

Report for 1-5 April: both "prerna" and "prerna1" are reported.

prerna
Level 2
Level 2
@yuhuisg- Yes! This is why I don't understand what might be wrong. I ran the report yesterday(with all the changes made) and this is what I saw 'prerna' -5 (instances). There is no instance of 'prerna1' and it's quite surprising.
ishans52004352
Employee
Employee

@arindamagarwal - It's likely we are missing something. Could you reach out to Adobe Client Care with the screenshot of the report and they will get back to you with an answer?

yuhuisg
Correct answer by
Community Advisor
Community Advisor

Have you verified your tag implementation, i.e. to ensure that the new value is indeed being tracked as expected?

View solution in original post

prerna
Level 2
Level 2
@yuhuisg- I did verify it. As I mentioned- I can see that the instances are getting incremented, but to the old value, not the new one
yuhuisg
Community Advisor
Community Advisor

What I meant is from your website instead, have you verified that the correct prop value is being tracked? E.g. with the Adobe Experience Cloud Debugger

jantzen_belliston-Adobe
Level 10
Level 10
Do any of the answers below answer your initial question? If so, can you select one of them as the correct answer? If none of the answers already provided answer your question, can you provide additional information to better help the community solve your question?