Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

Power BI and API timing out

marcush74174295
Level 2
Level 2

Hi,

 

So I have an annoying issue that I am not really sure what the best way to tackle it is... when querying for data in Power BI using the Adobe Analytics connector, if more than four days passes, it starts timing out. I have quite a complex query though, with five dimensions which I need to get data out per day for a couple of months. I know that the Adobe API is built more for quick, shorter queries, so this one just keeps timing out.

 

Two things that I am thinking about doing, is:

1) Split up the queries to daily instead, but I do not know how I would go about or even start to do that. Say my date range is 2021-01-01 to Today, I'd like to be able to split that up by day, query it per day and then append the queries to a new table. No idea how I'd go about doing that though... any tips would be helpful!

 

2) Break down one dimension at a time. The only common identifier I have is an ID that is the common between all dimensions. Say, for sake of simplicity, I'd have ID1, then I was thinking on querying the pages where ID1 was present for the remaining four other dimensions. I know how to do it in report builder, but I can't get the same to work in Power BI.

 

Any tips, thoughts or ideas would be highly welcome!

3 Replies
BernardoCF
Level 3
Level 3

Are you using the 1.0 or 2.0 (beta) API? I'm currently not able to edit my old query and fetch new data from that query onto Power BI. A refresh with the untouched query still works. My connection also times out. 

marcush74174295
Level 2
Level 2

Hi Bernardo, 

I am using the built in API connector which I believe runs on API 1.4. I am hoping they'd update it to 2.0, as I think it seems much more efficient in the few tests I have done myself outside of PBI.

BernardoCF
Level 3
Level 3

I've been doing more tests and the connection is problematic with any API version. It doesn't look like Adobe cares much about that API.