Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

postman authentication got failed with error 'Error: getaddrinfo ENOTFOUND ims-na1.adobelogin.com'.

Krishnakumar2004
Level 1
Level 1

When trying to request Token for OAuth in Postman got this error = 'Error: getaddrinfo ENOTFOUND ims-na1.adobelogin.com'. Any idea how to resolve this error.

1 Accepted Solution
shesingh
Correct answer by
Employee
Employee

Hi there,

This error seems to be coming due to the client ID and credentials placed while retrieving the access token. You need to make sure of the below settings:

  • Go to Postman (preferably the latest version).
  • Under "Authorization" tab, select "OAuth 2.0" as the "Type". Click on "Get New Access Token".
  • Token Name: Enter any name
  • Grant Type: Authorization Code
  • Callback URL: https://www.getpostman.com/oauth2/callback
  • Auth URL: https://ims-na1.adobelogin.com/ims/authorize/v1
  • Access Token URL: https://ims-na1.adobelogin.com/ims/token/v1
  • Client ID: Enter the Client ID captured from Adobe I/O integration details
  • Client Secret: Enter the Client Secret captured from Adobe I/O integration details
  • Scope: openid AdobeID read_organizations additional_info.projectedProductContext additional_info.job_function
  • State: can be left blank; it's optional
  • Client Authentication: Send client credentials in body
  • Click "Request Token". Experience Cloud login prompt will appear. Sign in using Adobe ID/Federated ID (the sign-in method should be identical to the one used to sign into Adobe I/O).
  • After successful sign-in, Access Token will be generated and appear in the pop-up window. Scroll down to the bottom of the page and click "Use Token".

If you still face errors, feel free to get in touch with the client care team(clientcare@adobe.com)

 

View solution in original post

5 Replies
shesingh
Correct answer by
Employee
Employee

Hi there,

This error seems to be coming due to the client ID and credentials placed while retrieving the access token. You need to make sure of the below settings:

  • Go to Postman (preferably the latest version).
  • Under "Authorization" tab, select "OAuth 2.0" as the "Type". Click on "Get New Access Token".
  • Token Name: Enter any name
  • Grant Type: Authorization Code
  • Callback URL: https://www.getpostman.com/oauth2/callback
  • Auth URL: https://ims-na1.adobelogin.com/ims/authorize/v1
  • Access Token URL: https://ims-na1.adobelogin.com/ims/token/v1
  • Client ID: Enter the Client ID captured from Adobe I/O integration details
  • Client Secret: Enter the Client Secret captured from Adobe I/O integration details
  • Scope: openid AdobeID read_organizations additional_info.projectedProductContext additional_info.job_function
  • State: can be left blank; it's optional
  • Client Authentication: Send client credentials in body
  • Click "Request Token". Experience Cloud login prompt will appear. Sign in using Adobe ID/Federated ID (the sign-in method should be identical to the one used to sign into Adobe I/O).
  • After successful sign-in, Access Token will be generated and appear in the pop-up window. Scroll down to the bottom of the page and click "Use Token".

If you still face errors, feel free to get in touch with the client care team(clientcare@adobe.com)

 

View solution in original post

Krishnakumar2004
Level 1
Level 1
I followed above steps after Click "Request Token". Experience Cloud login prompt has appeared. I have Signed in with adobe ID succesfull. But that signed in window not closed and there is no Token generated.
shesingh
Employee
Employee
Sure. The reason for that is the oAuth integration created in Adobe I/O should have https://www.getpostman.com/oauth2/callback as the "Default redirect URI" and https://www\\.getpostman\\.com as the "Redirect URI pattern".
Krishnakumar2004
Level 1
Level 1
We tried updating it. Now authorization is success but Token post request got failed. POST https://ims-na1.adobelogin.com/ims/token/v1 Error: getaddrinfo ENOTFOUND ims-na1.adobelogin.com
Krishnakumar2004
Level 1
Level 1
How to proceed with Post Token error. Now authorization is success but Token post request got failed. POST https://ims-na1.adobelogin.com/ims/token/v1 Error: getaddrinfo ENOTFOUND ims-na1.adobelogin.com