Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

New MID generated even with Old one instanciated in URL

Avatar

Level 3

Hi community,

 

I'm currently not able to track my visitor from my app to the webview.

 

already found lot of documentation like this one and this one. But it didn't fix my problem.

Currently, my third-party cookies are disabled (included demdex cookie) and I can't enable them. So I need to find a way to track the visitor without it.

When my user is on the app environment, a MID is generated. See the screenshot below from app context:

SS_Context_App.png

I achieved to save this ID in the URL when the user goes from the App context to the Webview context.

But my problem is that when the user is landing on the webview, a new MID is being generated even if the first one is instantiate in the URL.

See screenshot below from webview context:

SS_Context_Webview.png

You can see on the mid variable a new MID being generated. While the first one is stored in the URL in the g variable.

We reached Adobe customer care to learn more about that. They told us to use the method overwriteCrossDomainMCIDAndAID but it didn't help us here.

 

Does anyone have any suggestion?

Thank you

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

@Swanan_ ,

Customer Care suggested the right option. I have reviewed the property "da**v2" and the option overwriteCrossDomainMCIDAndAID is not enabled now in live. Could you confirm that it was set to true while you were testing that scenario?

 

View solution in original post

0 Replies

Avatar

Correct answer by
Community Advisor

@Swanan_ ,

Customer Care suggested the right option. I have reviewed the property "da**v2" and the option overwriteCrossDomainMCIDAndAID is not enabled now in live. Could you confirm that it was set to true while you were testing that scenario?

 

Avatar

Level 3

Hi @Andrey_Osadchuk 

 

I clicked a bit to fast on the "good answer" button lol sorry.

 

I didn't do the tests myself but I'll double check with my team in order to be sure that this has been done correctly.

 

Thank you for your feedback.

Avatar

Level 3

Hi @Andrey_Osadchuk 

So yes, I checked and the test has been done correctly.

 

Even if we set the option overwriteCrossDomainMCIDAndAIDto true, it's still generating a new MID when we are landing on the webview.

Is there any other settings I can modify to be sure that the MID will be catch from the URL and used as the "main MID" ? Or maybe anyother option to stop the generation of a new MID when we land on the webview ?

 

Is it a problem if the ECID i always the first rule triggered on each pages ? And especially when we land on the webview ?

 

Thanks a lot for your help

 

Avatar

Community Advisor

Did you correctly configure the ECID? E.g. were the tracking servers set?

 

P.S.: I would advise to open a support ticket to ask to troubleshoot the scenario you are working on.