Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Match Customer Attribute with Customer Id in AA

Avatar

Community Advisor

Hello guys,

 

I am sending Customer Attribute to customerId,age,etc to AA but I noticed that I have no ID matchs in AA and Custoemr Attribute. Any suggestion?

Thanks

1 Accepted Solution

Avatar

Correct answer by
Level 2

Hi @Luca_Lattarini 


First, check in 'ID Lookup' if your uploaded Customer IDs have an associated ECID. Now, make sure you have correctly implemented visitors.setCustomerIDs (if it's through AppMeasurement.js) or "Set Customer IDs" action if it's through Launch.

 

You may refer to this :
https://experienceleague.adobe.com/docs/launch-learn/implementing-in-websites-with-launch/implement-...

 

Thanks,

 

View solution in original post

0 Replies

Avatar

Level 7

@Luca_Lattarini When you have uploaded the CA file ? It takes sometime to match the IDs. Are you seeing any error in the CA screen ?

Avatar

Community Advisor

I uploaded yst at 9pm. I can see customer attribute in Report->Profile but there is no data as showed below

 

1982luca_0-1623295568035.png

My question is how can I map customer Id from Customer Attribute with customer id in AA?

Avatar

Level 7
To map the customer ids the Alias ID in the CA UI should match with the Integrated Code in the Experience Cloud ID extension. Can you please check the same ?

Avatar

Correct answer by
Level 2

Hi @Luca_Lattarini 


First, check in 'ID Lookup' if your uploaded Customer IDs have an associated ECID. Now, make sure you have correctly implemented visitors.setCustomerIDs (if it's through AppMeasurement.js) or "Set Customer IDs" action if it's through Launch.

 

You may refer to this :
https://experienceleague.adobe.com/docs/launch-learn/implementing-in-websites-with-launch/implement-...

 

Thanks,

 

Avatar

Level 7

@Luca_Lattarini Adding to @hjoshi  Make sure that the Integration Code used in the ECID extension in Launch has same name as Alias ID in the Customer Attributes screen.

Avatar

Level 10
Do any of the answers below answer your initial question? If so, can you select one of them as the correct answer? If none of the answers already provided answer your question, can you provide additional information to better help the community solve your question?