Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Marketing channel populated incorrectly

francescop47742
Level 3
Level 3

Hi to all,

 

I have a problem and I don't know the cause.

 

I have this setup where marketing channel "offline" is populated if in query string there is the word "offline"

 

2021-07-23_09h53_25.png

 

But in the marketing channel report i saw that this traffic goes to "direct" channel.

 

2021-07-23_10h00_28.png

 

how is it possibile? do you have any ideas?

 

thk,

francesco

 

 

 

 

 

1 Accepted Solution
yuhuisg
Correct answer by
Community Advisor
Community Advisor

Instead of using the Visits metric, what does the table show when you use the Marketing Channel Instances metric?

View solution in original post

12 Replies
yuhuisg
Correct answer by
Community Advisor
Community Advisor

Instead of using the Visits metric, what does the table show when you use the Marketing Channel Instances metric?

View solution in original post

francescop47742
Level 3
Level 3

Hi @yuhuisgm

thk for reply, event with Marketing Channel Instances metric I see the problem 😞 

 

do you have any ideas?

yuhuisg
Community Advisor
Community Advisor
Is your Direct Channel set to override the last-touch channel?
francescop47742
Level 3
Level 3
no, internal and direct dosn't override last-touch channel, any other ideas? 😞
yuhuisg
Community Advisor
Community Advisor
What are the Expiration and Allocation settings for your "Query String" dimension? (The dimension used in your freeform table.)
francescop47742
Level 3
Level 3
The expiration is visit and allocation "most recent". BTW I fixed changing the processing rule using "tracking code" instead "query string" 🙂
yuhuisg
Community Advisor
Community Advisor

@francescop47742‎I don't think that processing rule change is a cause for this. BUT I do think that your eVar's expiration is a factor in your report.

Recall that Marketing Channels are processed with every hit. And a visit consists of many hits. In AA, a visit will not change if the tracking code changes. So what your report could be showing is that for some visits, users' Marketing Channels are being changed after some hits, e.g. to "Direct". But their hits are still coming in close enough that they comprise the same visit.

As a result, your Query String Parameter is being correlated with other Marketing Channels.

hjoshi
Level 2
Level 2

As I can see in the workspace you are using "Visit" metric in Marketing channel report.If we are looking into a marketing channel report in Adobe Analytics, the Adobe recommends using only the "Marketing channels instances" metric.

 

This metric measures the number of times a marketing channel was defined in an image request, including standard page views and custom link calls. Does not include persisted values.

https://docs.adobe.com/content/help/en/analytics/components/marketing-channels/analyze-mc.html

 

Instances show the total number of times that a user clicked to your website and the Marketing Channel changed. Similar to its use in other analytic tools, the Marketing Channel persists beyond the initial click-through until the user clicks through from another campaign or referring domain. Visits here means the total number of visits where the most recent Marketing Channel was, such as email. Therefore, Marketing Channel Instances here gives the total number of clicks from email.

alexjbaker11
Level 2
Level 2

Have you ensured you've typed in "utm_medium" rather than "utm_medium=" ?

TomEdmondson
Level 1
Level 1

We don't see your direct rule but I take it, it is below this one looking at your screenshot. Are you looking at a date range that is post the change/creation of the rule?

francescop47742
Level 3
Level 3
Hi tom and thk for reply 🙂 I never change the rule so I don't know why this happen now. The expiration is visit and allocation "most recent". BTW I fixed changing the processing rule using "tracking code" instead "query string" 🙂