Expand my Community achievements bar.

Announcement: Calling all learners and mentors! Applications are now open for the Adobe Analytics 2024 Mentorship Program! Come learn from the best to prepare for an official certification in Adobe Analytics.
SOLVED

eVars not showing as option in Reports

Avatar

Level 2

I have defined a series of custom eVars and can see them in the debugger, however they are not available as an option in Reports. What am I missing?

1 Accepted Solution

Avatar

Correct answer by
Level 4

Hey @bobc76334831 - Can you double check if the evars are enabled in the report suite ? Sometimes it is enabled in the dev report suites and disabled in prod, may be this is a basic check, but didn't want to assume. Also, lyou can go to Key Metrics report and check the actual latency for the report suite in question, as seen below.

RaawiMahendru_0-1645032157224.png

 

View solution in original post

3 Replies

Avatar

Employee

Hi @bobc76334831,

The custom eVar values that you see in the debugger is not immediately available in Analytics Workspace and Reports.

It can take upto 2 hours to reflect in the reporting depending on the latency on your report suite.

 

Other things that you should consider checking:

  • if correct tracking server is configured
  • if the data is being sent to the correct report suite
  • if the eVar is enabled for that report suite

Hope this helps! 

 

Avatar

Employee

Hi @bobc76334831! Generally, a variable (prop or evar) need up to 90 minutes for appear in report. However, if you want the value immediately, please confirm on Report & Analytics with "Include Current Data". 

Please confirm below URL about Current Data as well.

 

- Current Data

https://experienceleague.adobe.com/docs/analytics/analyze/reports-analytics/current-data.html?lang=e...

 

Thanks!

Avatar

Correct answer by
Level 4

Hey @bobc76334831 - Can you double check if the evars are enabled in the report suite ? Sometimes it is enabled in the dev report suites and disabled in prod, may be this is a basic check, but didn't want to assume. Also, lyou can go to Key Metrics report and check the actual latency for the report suite in question, as seen below.

RaawiMahendru_0-1645032157224.png