Connecting to Power BI

Avatar

Avatar

nataliap1852673

Avatar

nataliap1852673

nataliap1852673

31-07-2018

Hi

Trying to connect Power BI to Adobe Analytics but after I put in my Adobe ID it is giving me a grey screen.

Could you help?

Thanks

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

matth87885335

Avatar

matth87885335

matth87885335

05-12-2018

Natalia,

I was having the same problem and may have a fix for you.

Using Wireshark and Fiddler, we were able to find the login request url that Power BI Desktop uses. It starts with something like:

"https://ims-na1.adobelogin.com/ims/authorize/v1?client_id=MarketingCloudWS1&redirect_uri=https....."

Taking the complete url from the login request, I pasted it into Chrome and the Adobe Marketing Cloud login appeared. After entering my credentials and logging in, the Chrome screen turned blank.

I then re-opened Power BI Desktop and began the Get Data connection process to Adobe. Power BI immediately established a connection, bypassing the login prompt, and I was able to access our Adobe data in Power BI.

I am, however, experiencing an issue where I can only see 1 of the 3 Instances to which I have access. This may be due to the workaround in connecting to Adobe but I'm not sure. I have another ticket open with Client Care to investigate.

But please feel free to attempt this workaround and hopefully it works for you!

Good luck!

- Matt

Answers (10)

Answers (10)

Avatar

Avatar

jeffshieldsdev

Avatar

jeffshieldsdev

jeffshieldsdev

10-07-2019

Here's the workaround for the grey screen in Power BI Desktop during authentication: Re: Unable to connect Adobe Analytics to Power BI ... - Microsoft Power BI Community

Avatar

Avatar

timwilson7

Avatar

timwilson7

timwilson7

05-12-2018

Thanks, Matt!

Since I was bumbling along a little bit (and working to get this working on a Windows VM that was a pretty fresh install), I'll add a couple more bits of detail:

  1. Download Fiddler
  2. Make a filter for Show only if URL contains adobelogin
  3. Launch Power BI Desktop and go to Get Data and select the Adobe Analytics connector
  4. At some point, walking through the (failing) login process, you'll see the request appear in Fiddler and you can copy the URL (starts with the pattern above and is a bit of a beast)
  5. Paste that into your browser and you'll get prompted to log in with your Adobe ID and then click to authorize the connector.
  6. Return to Power BI Desktop and cancel out of the login process (maybe not necessary, but that's what I wound up doing).
  7. Start the Adobe Analytics connector again, and you should show as already being connected and be good to go!

Thanks again for figuring that out, Matt. I'd pretty much thrown up my hands and given up.

Avatar

Avatar

trishac37070932

Avatar

trishac37070932

trishac37070932

02-07-2019

I am experiencing the same issue. I am working on a windows VM.  When I try to login it goes to a grey screen and login fails. Its only happening for me and not my coworkers. I tried the steps above that Matt shared and that didn't fix it. This is very frustrating.

Avatar

Avatar

Gigazelle

Employee

Avatar

Gigazelle

Employee

Gigazelle
Employee

19-11-2018

Hey Tim, great seeing you here. While I don't have an answer to the Power BI issue, I've reopened the question so we can hopefully get some additional input.

Avatar

Avatar

timwilson7

Avatar

timwilson7

timwilson7

18-11-2018

Gigazelle​ While nataliap18526733​ has not responded, I don't think this post should be assumed answered. I am experiencing this issue as well, as is jackcbennett​. The steps I'm following:

  1. Selecting Adobe Analytics as the Data Connector from within Power BI Desktop
  2. I get told to sign in with my Adobe ID in a pop-up window.
  3. I enter my Adobe ID username and password and click Sign In.
  4. The popup just goes to all gray. If I move it out of the way, the original prompt is saying "You are being signed in, please wait..." And there is a "Sign in..." message on a button with the spinning circle.

Nothing happens from there. IF I close the gray popup window, then the original prompt changes back to just saying "You are not signed in" with a "Sign in" button below it. But there is also a yellow ribbon that says, "We're unable to connect. Please delete your credentials and try again later."

I'm not sure how/where to delete my credentials.

I'm trying this on a pretty clean Windows 10 install with a fresh Power BI Desktop install.

Any ideas?

Avatar

Avatar

jackcbennett

Avatar

jackcbennett

jackcbennett

16-11-2018

Hello, did you ever resolve this? We're experiencing the same issue so would be great to know if you managed to get any further!

Thanks,

Jack

Avatar

Avatar

Gigazelle

Employee

Avatar

Gigazelle

Employee

Gigazelle
Employee

07-11-2018

Hi Natalia, were you able to get the issue resolved?

Avatar

Avatar

PratheepArunRaj

Moderator

Avatar

PratheepArunRaj

Moderator

PratheepArunRaj
Moderator

01-08-2018

Dear Natalia,

If you cannot raise Adobe Customer Care request, you are not supported user for Adobe Analytics.

Contact your Adobe Analytics Account Manager and they should definitely help you.

Thank You

Arun

Avatar

Avatar

nataliap1852673

Avatar

nataliap1852673

nataliap1852673

01-08-2018

Hi Arun,

It is not a connection from Report Builder I am trying to connect from Power BI Desktop to Adobe Analytics as a data source. It works for my colleague so should be some issue with my User ID from Adobe side. I emailed Customer Care email but autoreply says my email is not supported which is very strange.

Natalia

Avatar

Avatar

PratheepArunRaj

Moderator

Avatar

PratheepArunRaj

Moderator

PratheepArunRaj
Moderator

01-08-2018

Dear Natalia,

Have you verified that you are using the latest version of Report Builder? If not, please update.

Then try to follow the trouble shooting techniques from the links Troubleshooting Power BI Integration  and Troubleshooting and Best Practices for Report Builder. If not, kindly reach Adobe Customer Care : CustomerCare@adobe.com.

Thank You

Arun