Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Advertising Analytics - AMO Classification Issue

brettf35967596
Level 1
Level 1

Hi - We have implemented Advertising Analytics for Adobe Analytics and the AMO ID and respective metrics are coming through as expected (AMO Impressions, AMO Cost, AMO Clicks, etc).  The issue we have is that the AMO classification variables (Account, Ad Type, Keyword, etc) are not being set and are all showing 'unspecified'.  I searched all the documentation and help files and do not see any set up or configuration steps that we may have missed.  Everything leads me to believe that this classification is set up by default upon configuring the report suite.  Any help would be appreciated.

1 Accepted Solution
Urs_Boller
Correct answer by
Community Advisor
Community Advisor

have you selected manual or automated appending of the query string parameter? basically all traffic that arrives from the google ads account should have an additional parameter "s_kwcid". what you can do to check:

a) create a table and see if you have "AMO ID" with "occurrences"? if there are no occurrences, you have an issue in tagging the links in the ad account

b) create a processing rule and write the parameter "s_kwcid" in a prop. just to see if you really do not get any values on the incoming links

if you have occurrences and you have waited some days after setup and the first incoming traffic, reach out to CC to check the setup in the backend

View solution in original post

0 Replies
Urs_Boller
Correct answer by
Community Advisor
Community Advisor

have you selected manual or automated appending of the query string parameter? basically all traffic that arrives from the google ads account should have an additional parameter "s_kwcid". what you can do to check:

a) create a table and see if you have "AMO ID" with "occurrences"? if there are no occurrences, you have an issue in tagging the links in the ad account

b) create a processing rule and write the parameter "s_kwcid" in a prop. just to see if you really do not get any values on the incoming links

if you have occurrences and you have waited some days after setup and the first incoming traffic, reach out to CC to check the setup in the backend

jsvasu
Level 3
Level 3
@Urs_Boller Does configuring Advertising Analytics interferes with the existing metrics and dimensions? Can we configure Advertising Analytics mapped to the production main website's report suite? Only concern is it will not hamper any other metrics and dimension of the main website's report suite?
Urs_Boller
Community Advisor
Community Advisor

hi @jsvasu. No, Advertising Analytics should not interfere with the existing setup - unless you manually change something that affects your current setup. Basically, when setting up the connection, you will get the data in new dimensions ("AMO ID" and classification) and events (AMO events) which will appear in the Analytics interface. So you do not take your existing dimensions/events but new ones.

Here some more technical details: you add the "s_kwcid"-Paramater within the search ads account (eg. google ads), basically this ads the new parameter to each landing page url. so when a user clicks on an ad and lands on your site, analytics will read this query parameter automatically (remark: this is done server side, so you wan't see any changes on the tracking call). you are free to use your existing tracking code setup next to this new parameter (which is what we do in our setup). this means, each landing page link in the ads has both parameters in the url

Appart from the landing page link the integration will fetch the data by API in the backend each day (this is why you need the authentication while setup). Basically it fetches the desired data (on a daily basis) and pulls it at "summary data" into Adobe Analtics. thanks to this setup, you can see cost, impressions, clicks and more from your ads account directly in Adobe Analtics.

brettf35967596
Level 1
Level 1

The parameter is on the links and is getting assigned to the AMO ID.  We are also able to see Occurrences and other Metrics for the AMO ID such as Cost, CPC, etc.  The only issue we have is the other AMO variables (classification) are not getting assigned.

Urs_Boller
Community Advisor
Community Advisor

I would suggest to contact ClientCare - there seems to be something wrong. the only case where it didn't work for me were google display ads (setup in the same google ads account but they are not search ads!)

brettf35967596
Level 1
Level 1

Thanks - I do have a ticket opened with client care and am waiting to hear back from them.

adamt16229560
Level 2
Level 2

@brettf35967596 did you resolve this issue? I'm currently seeing the same thing - I have one integration that was set up a while ago which is working fine, but the ones I've added over the past few days are all coming through as unspecified. 

jantzen_belliston-Adobe
Level 10
Level 10
Do any of the answers below answer your initial question? If so, can you select one of them as the correct answer? If none of the answers already provided answer your question, can you provide additional information to better help the community solve your question?