Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AAM is throwing error 's.AudienceManagement.setup() is not a function'

Avatar

Level 2

Hi team,
I see s.AudienceManagement.setup() is not a function error as we have just upgraded app measurement and moved from custom library to managed by Adobe and trying to load AAM using AppMeasurement_Module_AudienceManagement JS with the function s.loadModule("AudienceManagement");because we want to load AAM conditionally. Do we have any updated AAM library to resolve this issue? 

11 Replies

Avatar

Community Advisor

Hi @Pranithakat 

I believe you're using Adobe Launch (now called, Data Collection) for your implementation. 

 

When you're using the option Managed the Library for me which is in Adobe Analytics extension, in the same extension you can see the configuration settings for Audience Manager which share Analytics data with Audience manager. 

 

Now, when you say you need to load the AAM conditionally, what condition?  

Avatar

Level 2

@gokula Condition is to load AAM module only for few domains with container Id set as 1 or 2 which is coming from our datalayer.

Avatar

Community Advisor

Hi @Pranithakat 

In this case, have you tried the Adobe Audience Manager (DIL) extension that comes with latest DIL version 9.5. ( Note- This extension is not meant to be used for Server side forwarding)

Once you installed extension you need to setup the launch rule, add the condition for your domain where it needs to be loaded, and under the action you need to setup the action run custom code, that will give you basic example of sending data to audience manager. 

 

This extension added the basic AAM library code for you, however you need to send any data that you want from the page by using Submit and Signal methods and then you can create a trait in AAM. 

 

Hope this helps. 

Avatar

Level 2

Thanks @gokula , it is helpful and this was my next option. Can you confirm if we don't have any  updated AppMeasurement_Module_AudienceManagement library which I can just replace instead of going with new implementation.

Avatar

Community Advisor

Hi @Pranithakat  

Yes you can download latest AppMeasurement code from Code Manager 

You need log in to Adobe Analytics interface and then follow below path 

Analytics -> Admin -> All Admin -> Code Manager 

 

Once you're in Code Manager you can see latest AppMeasurement (JavaScript) version 2.22.4 with documentation and download link. 

 

Download the zip file, extract it and you can see AppMeasurement_Module_AudienceManagement.js 

 

Hope this helps.  

Avatar

Moderator

Dear Pranithakat,

I might be silly, but still want to give my view.

Your code was working fine when you use Custom Library right? If that the case, checkout the difference between the version. Even if you use library managed by adobe, you can still add codes to the library using Custom Editor. Try out the method and see if it works.

Thank You, Pratheep Arun Raj B (Arun) | NextRow DigitalTerryn Winter Analytics

 

Avatar

Level 2

Hi @PratheepArunRaj ,

Thanks for the reply. Yes it was working with old app measurement library which was version 2.20. Now its 2.22.4, tried with old(9.3) and latest AAM(9.4) library code in custom editor which didn't work.

Avatar

Community Advisor

Hey @Pranithakat 

Can you compare the revisions and see the changes so you can troubleshoot your issues. 

If possible, can you put screenshot of your implementation or error? 

Avatar

Moderator

So, libraries are not causing the problem, but the implementation. Need more details or someone who already faced this issue should advice here.

Avatar

Moderator

Where are you calling the function s.AudienceManagement.setup()?

Check whether it is called before the load of the extensions.