Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

AA Beacon has two network requests- 302 followed by 200

StewSchilling
Community Advisor
Community Advisor

Can anyone explain what is happening here?  I see this occasionally.  It tends to be at the beginning of a session.

I originally thought that I had some issue in my code that was causing two beacons to be sent.  I finally caught it in the network tab this AM.

I now think that this is normal behavior, but I don't fully understand the "Why" of it.

Any help?

Screen Shot 2019-02-13 at 8.31.56 AM.png

1 Accepted Solution
ishans52004352
Correct answer by
Employee
Employee

Hi stewarts16448458​,

The first 302 beacon is a redirect beacon that is used to set the s_vi cookie. Once the s_vi cookie is set, you won't see such 302 beacons (unless the cookies are cleared). The second 200 beacon is the actual beacon sent to Analytics servers.

This is an expected behavior and shouldn't be considered as duplicate beacons.

Hope this clarifies!

View solution in original post

3 Replies
ishans52004352
Correct answer by
Employee
Employee

Hi stewarts16448458​,

The first 302 beacon is a redirect beacon that is used to set the s_vi cookie. Once the s_vi cookie is set, you won't see such 302 beacons (unless the cookies are cleared). The second 200 beacon is the actual beacon sent to Analytics servers.

This is an expected behavior and shouldn't be considered as duplicate beacons.

Hope this clarifies!

View solution in original post

StewSchilling
Community Advisor
Community Advisor

Thank you!  I would assume that this does not happen when using ECID service. Right?

randy_floyd
Level 1
Level 1
A little late to the party here... 🙂 But It DOES happen with ECID.