Skip to main content
Level 3
December 27, 2022
Risolto

Unable to publish a page after SP14 upgrade

  • December 27, 2022
  • 2 risposte
  • 822 visualizzazioni

Hello,

 

We are upgrading to AEM 6.5 with SP14 from SP7. After upgrade Pages are not publishing (quick publish, Mange publish or direct publish from edit page).

We are unable to reproduce this issue in local instance, only happening on actual servers.

 

Shown below seeing ERROR Failed to retrieve references for the selected page. Anyone else is facing similar issue with SP14 upgrade.

 

 

 

Questo argomento è stato chiuso alle risposte.
Migliore risposta di NarayanaCh

I have noticed below error in the error.log

27.12.2022 15:51:36.152 *WARN* [127.0.0.1 [1672181496136] POST /libs/wcm/core/content/reference.json HTTP/1.0] 
org.apache.sling.jcr.resource.internal.JcrSystemUserValidator The provided service principal name
'commerce-reader-service' is not a known JCR system user id and therefore not allowed in the
Sling Service User Mapper.

 Based on that I have created system user "commerce-reader-service" then it started working

2 risposte

Himanshu_Singhal
Community Advisor
Community Advisor
December 27, 2022
NarayanaChAutoreRisposta
Level 3
December 27, 2022

I have noticed below error in the error.log

27.12.2022 15:51:36.152 *WARN* [127.0.0.1 [1672181496136] POST /libs/wcm/core/content/reference.json HTTP/1.0] 
org.apache.sling.jcr.resource.internal.JcrSystemUserValidator The provided service principal name
'commerce-reader-service' is not a known JCR system user id and therefore not allowed in the
Sling Service User Mapper.

 Based on that I have created system user "commerce-reader-service" then it started working