Skip to main content
Level 3
May 9, 2017
해결됨

Signature step not showing pdf

I have setup scribble signature on my adaptive form and also a signature step just below the scribble signature component.

The scribble signature works well in preview, but the signature step isn't show the pdf, it just says loading...

Any reason why the pdf isn't showing? i am using chrome and also have installed the chrome pdf viewer, still no luck.

이 주제는 답변이 닫혔습니다.
최고의 답변: Sakshi5

'Signature Step' should be the only component in a panel. You should not have any other field with it. Generally its used in child panel of a panel having wizard layout, hence the name 'Signature Step'.

PS: https://helpx.adobe.com/aem-forms/6-3/signing-forms-using-scribble.html 

16 답변

Adobe Employee
May 10, 2017

What is your server OS? Also are you able to preview DOR associated with AF in the edit mode

paultjw작성자
Level 3
May 10, 2017

the server os is windows 10, i was able to preview the dor fine in edit mode, it failed in preview mode.

Adobe Employee
May 10, 2017

are you able upload a xdp and then preview the xdp as HTML ?

paultjw작성자
Level 3
May 10, 2017

it wouldn't preview, throws an error:

Internal Server Error

Cannot serve request to /content/dam/formsanddocuments/temp.xdp/jcr:content in /libs/xfaforms/render/GET.jsp

Exception:

com.adobe.forms.service.LCFormsServiceException at com.adobe.forms.service.impl.LCFormsOsgiServiceImpl.render(LCFormsOsgiServiceImpl.scala:92) at com.adobe.forms.service.impl.LCFormsServiceImpl.render(LCFormsServiceImpl.java:68) at org.apache.jsp.libs.xfaforms.render.GET_jsp._jspService(GET_jsp.java:124) at org.apache.sling.scripting.jsp.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70) at javax.servlet.http.HttpServlet.service(HttpServlet.java:725) at org.apache.sling.scripting.jsp.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:502) at org.apache.sling.scripting.jsp.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:449)
Adobe Employee
May 10, 2017

So it looks like your installation is not proper. Are there any spaces in the path of your installation directory? How did you start your server? Did you use a batch file? Or double clicked the jar file? Are all your bundles in active state?

paultjw작성자
Level 3
May 10, 2017

nope, no spaces : D:\AEM6.3

started as a windows service

bundles all active