Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Error using debugger with adobe IO actions.

Nikhil-Kumar
Community Advisor
Community Advisor

Hi All,

Getting below error while using Debugger in adobe io action:

 


Ready, waiting for activations! Use CTRL+C to exit
Activation: 25814aa7acea4aa3814aa7acea0aa38a
2020-11-05T16:29:12.398684400Z Trying to get remote schemas from aio-lib-state cache ...
2020-11-05T16:29:14.379643716Z 2020-11-05T16:29:14.379Z @adobe/aio-lib-state:error {
2020-11-05T16:29:14.379702016Z "sdk": "StateLib",
2020-11-05T16:29:14.379713916Z "sdkDetails": {
2020-11-05T16:29:14.379721316Z "key": "schemas"
2020-11-05T16:29:14.379728616Z },
2020-11-05T16:29:14.379735316Z "code": "ERROR_BAD_CREDENTIALS",
2020-11-05T16:29:14.379742416Z "message": "[StateLib:ERROR_BAD_CREDENTIALS] cannot access underlying DB provider, make sure your credentials are valid",
2020-11-05T16:29:14.379750316Z "stacktrace": "StateLibError: [StateLib:ERROR_BAD_CREDENTIALS] cannot access underlying DB provider, make sure your credentials are valid\n at new <anonymous> (/code/Node_code_Repo/lead2loyaltyaio-nodejs/node_modules/@adobe/aio-lib-core-errors/src/AioCoreSDKErrorWrapper.js:33:9)\n at _wrap (/code/Node_code_Repo/lead2loyaltyaio-nodejs/node_modules/@adobe/aio-lib-state/lib/impl/CosmosStateStore.js:32:37)\n at process._tickCallback (internal/process/next_tick.js:68:7)"
2020-11-05T16:29:14.379762616Z }


@mhaack @Mihai_Corlan 

1 Accepted Solution
duypnguyen
Correct answer by
Employee
Employee

Hi @Nikhil-Kumar - From the error logs, it seems you are using @adobe/aio-lib-state. Please note that, it is not possible to use wskdebug here because the debugger would create a local clone of the action which can not access the DB behind the State SDK (unless you configure it to use your cosmos DB instead of the available one in Runtime).

View solution in original post

1 Reply
duypnguyen
Correct answer by
Employee
Employee

Hi @Nikhil-Kumar - From the error logs, it seems you are using @adobe/aio-lib-state. Please note that, it is not possible to use wskdebug here because the debugger would create a local clone of the action which can not access the DB behind the State SDK (unless you configure it to use your cosmos DB instead of the available one in Runtime).

View solution in original post