Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Did anyone created segment based on PROFILE ATTRIBUTE and shared in AT?

Avatar

Level 2

I have use case to create a segment based on profile attribute and share in AT. In AT we have XT campaign to serve the content.

 

When I create a segment in AEP based on profile attribute, i can see that user qualify for that segment (Under Segment Membership) but content is not being served based on segment (its always serving default content).

Here is the steps we have already configured:

1. Profile Merge policy is enabled

2. Segment in enabled to flow into AT

3. "Segments to Schedule" Flag is turn ON

 

Note: Event based segment is working fine after following the same steps, we are only facing issue while creating a segment based on profile attribute.

 

Sequence for Event firing on page:

1. WebSDK fire on page load

2. Invoked AT with websdk to fetch content

window.alloy('sendEvent', {
xdm: {
_experience: {}
},
decisionScopes: ['alloy-5', 'seat-1']
}).then(function(result) {
console.log(result)
});

 

Not sure what i am missing here, any input will be helpful.

 

Thanks

1 Accepted Solution

Avatar

Correct answer by
Level 2

Thanks for the response!

 

Basically the issue was that, the segment i created in AEP was categories as streaming (since it was profile based) and after consulting with adobe customer support i heard that there is some issue on Adobe side on sending streaming & batch segment data to Target (as destination). Adobe engineering team is working to get it resolve.

 

So bottom line is, i was doing exactly as per AEP documentation but because of issue in the Adobe side i was not getting result.

View solution in original post

5 Replies

Avatar

Level 4

Will try it next week. If anything clicks, i will let you know

Avatar

Community Advisor

Interesting scenario, will try from my end and let you know!

Avatar

Correct answer by
Level 2

Thanks for the response!

 

Basically the issue was that, the segment i created in AEP was categories as streaming (since it was profile based) and after consulting with adobe customer support i heard that there is some issue on Adobe side on sending streaming & batch segment data to Target (as destination). Adobe engineering team is working to get it resolve.

 

So bottom line is, i was doing exactly as per AEP documentation but because of issue in the Adobe side i was not getting result.