Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Translated non-en languages still pointing to EN after translations

prash0905
Level 1
Level 1

Hi Team macdonald2008 

I am new to AEM and currently working MSM project. I need help with the below issue.

 

When a new page is created, language master is pointing to en. When the language copy from en to zh, Currently all the reference links are pointing to en post translation, it had to be manually updated to the respective languages

 

Example: 

source path:/content/xxx/language-masters/en/xxx/abc

destination path: /content/xxx/language-masters/zh/xxx/abc

 

The zh language copy is still having references (images, footers, experience fragments) pointing to en.

 

Please let me know the process of how to convert these references to zh.

 

 

 

 

1 Accepted Solution
Prince_Shivhare
Correct answer by
Community Advisor
Community Advisor

If you are using RTE somewhere in your site, it won't change the links. you might have to write some utility to change if RTE.

View solution in original post

4 Replies
SivaPrasadReddyS
Level 7
Level 7

@prash0905 , if you're talking about experience fragments, OOTB experience fragments references will not be updated based on site. Either you need to manually update experience fragments specific to the site or create custom rollout config to convert the links automatically.

 

Please check https://exadel.com/news/aem-experience-fragments-rollout-configuration/ for custom rollouts.

 

you can try to installl wknd master project on local and understand basic how live copy/language copy works, links are updated based on site specific etc..

https://github.com/adobe/aem-guides-wknd 

 

Thanks

 

 

 

prash0905
Level 1
Level 1

Hi Siva

 

Thanks for your reply. 

Yes, I am referring to custom experience fragments (not ootb) and also Images, Footer, Navigation etc.

Currently we are updating it manually which is taking very long.

Are there any other options to update the links to the respective language post translations. (connectors or any API or custom code).

 

Thanks and Regards

Prashanthi

Prince_Shivhare
Correct answer by
Community Advisor
Community Advisor

If you are using RTE somewhere in your site, it won't change the links. you might have to write some utility to change if RTE.

View solution in original post

prash0905
Level 1
Level 1

Hi Shiv

Thanks for your reply.

Could you please let me know what kind of utility. Are there any references to create such utility ??

We are using RTE in 1 or 2 pages in the site, but the page which I am translating is not having RTE however the translated page is still pointing to en references.

Please let me know if any other options to update the links to the respective language post translations. (connectors or any API or custom code).

Thanks and Regards

Prashanthi