Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SAML 2.0 Authentication Handler - successful login but redirect to blank page / 404

Avatar

Level 1

Hi, I am implementing Single-Sign-On (SSO) in AEM, so that user will not use the native AEM sign-in but instead using our company SSO to login. The issue I've been getting is that, everytime after the login is successful, it did not redirect me to the AEM dashboard, but instead it either gives me a blank page OR 404 page. We can only verified if we are successfully login is to use the direct URL to the dashboard. 

 

Can I know if anyone is facing this or is there any resolution to this? And is this valid https://helpx.adobe.com/uk/experience-manager/kb/SAML-redirection-to-originating-page-doesnot-work-A... ?

 

Reference: https://experienceleague.adobe.com/docs/experience-manager-64/administering/security/saml-2-0-authen...

0 Replies

Avatar

Community Advisor

Hi @Jansen 

 

Have you configured "Default Redirect" in the SAML 2.0 authentication handler? This is where the user is redirected after successful authentication. Kindly configure this field to the whereever you want user to land after login. Let me know if you still face any issues.

 

Thanks,

Avatar

Community Advisor

Is "/content/desktop/en.html" a valid path? Can you hit <protocol>://<domain_name>/content/desktop/en.html ?

Avatar

Community Advisor

No what i meant was is "/content/desktop/en.html" a valid path?

And also can you let me know the url it is landing to (404/bank page as mentioned in the post) after successful login?

 

Thanks,

Avatar

Level 3

I totally agree with @JeevanRaj . 

@DuDan you have to give the absolute path which will lead to dashboard. Taking the path from the "/content". Also, to debug the issue check your log, you will get the hint where it's causing the issue.

Avatar

Community Advisor

@Jansen 

  • Let us know after successful login - where you are getting redirected to ?
  • What's the page response you are getting when you try to access https://author:4502/content/desktop/en.html ? 
  • Create a logger called saml.log and tail the saml logs while logging into AEM.

 

Can you please review the "Default Redirect" configuration:

Rajakp_0-1645179082936.png

Also - try to update the complete path in the Default Redirect configuration - https://author:4502/content/desktop/en.html.

 

Regards,

Raja

Avatar

Community Advisor

Hi - can you share the screenshot the SAML configuration what you have configured so that we can debug the issue further.

We need to verify the IDP URL , Default Redirect , Service Provider URL from the SAML configuration.

 

Regards,

Raja