Refused to apply style from {css file} because not a supported stylesheet MIME type, and strict MIME checking is enabled.

Avatar

Avatar

rajeevy89244319

Avatar

rajeevy89244319

rajeevy89244319

03-10-2018

[Thread Edited By Adobe]

/*Don’t forget to meet and greet your fellow peers virtually by telling them about yourself here

Go ahead and to it now: https://adobe.ly/3eDnB4v */

 

Actual Post:

Whenever I am adding debugClientLibs query string in author instance, css files from apps folder are not loading. I am seeing below errors in browser console:

 

Refused to apply style from Refused to apply style from 'http://IP:4502/apps/core/wcm/components/image/v2/image/clientlibs/site/css/generated/image.css' because its MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled. because its MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled.

 

Has anyone experienced this issue and how it can be resolved?

 

AEM version is 6.3.2.0

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Veena_Vikram

MVP

Avatar

Veena_Vikram

MVP

Veena_Vikram
MVP

03-10-2018

Eventhough I have never experinced this issue before, just did a bit of google and found similar issues in different context. See if any of these helps you?

html - Stylesheet not loaded because of MIME-type - Stack Overflow

Which browser are you using ? Seems like lot of people using different technologies have reported this as an issue in Chrome https://discourse.roots.io/t/mime-type-text-html-not-a-supported-stylesheet-mime-type/11636/10

Still not sure of the possible causes or solution . Could you please share a sample component which we can use to reproduce the issue ? and give us steps to reproduce if possible

Thanks

Veena

Answers (0)