Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Query Builder doesn't give results specifically on the Chinese site

chinthakasuse
Level 2
Level 2

Hi All, I kindly need a help if someone has any idea. I have recently worked on search implementation for a multi site setup. It is working fine on all languages ( arabic, french, japanese) except specifically on chinese. I have used Query builder API along with Lucene indexing. I debugged but the query won't give any result on any query with chinese characters. I have tested on http://localhost:4502/libs/cq/search/content/querydebug.html . 

 

If you have any idea to overcome this issue please let me know. It would be greatly appreciated.

1 Accepted Solution
amogh-personal
Correct answer by
Level 2
Level 2

AEM by default support most of the language search with query builder API. So make sure you are reading the search team in request parameter using UTF-8 format.

Thanks,
Amogh

View solution in original post

4 Replies
Basavaraj_K
Level 2
Level 2

Hello,

I had same issue with Chines(zh),Japines(ja),Korean(ki) languages, As you know these are differs from other languages representation.

For time being I have fixed this by targeting the languages and changing the querybuilder API parameters as below.

 

parms.put("property", "key");

parms.put("property.value","%"+value+"%");

parms.put("property.operation", "like");

 

You can try out this for time being if it fulfills your requirements.

kautuk_sahni
Community Manager
Community Manager
Thank you for sharing the solution. This would help in posterity.
amogh-personal
Correct answer by
Level 2
Level 2

AEM by default support most of the language search with query builder API. So make sure you are reading the search team in request parameter using UTF-8 format.

Thanks,
Amogh

View solution in original post