Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Issues with AEM Translation Integration Framework

Avatar

Level 1

Hello there, 

We’re having some issues with the AEM translation framework.  

We are using an external connector to send pages in translation to an external Translation Management System (TMS). The external connector relies completely on the new AEM Translation framework. 

All the translation projects we create, are configured with the “Automatically Promote Translation Launches” and “Automatically Approve Translations” properties. 

edodemuru_0-1662129748338.png

 

 

When the translation job comes back from the TMS, it seems the translation has been automatically approved, as can be seen below. 

edodemuru_1-1662129748339.png

 

 

However, the status of the translation project remains stuck on the status “Ready For Review”. 

 

edodemuru_2-1662129748340.png

 

 

The launcher has not been deleted from the instance and the translation is not visible on the localized page. 

This is happening only on a few translation projects, not on all of them, but it seems a random behavior. It seems like when the translation comes back to AEM, some sort of listener is not activated and the status remains as it was, even if it should have been approved. 

Does some else experienced similar issues with the translation framework?  

We are using AEM 6.5.12. 

 

Let me know if you need more details. 

 

Thanks,

Edoardo

0 Replies