Installed 6.5.4 SP RRD already closed Exception

Avatar

Avatar
Validate 1
Level 3
sdouglasmc
Level 3

Likes

22 likes

Total Posts

83 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Give Back
Ignite 1
Boost 5
Boost 3
View profile

Avatar
Validate 1
Level 3
sdouglasmc
Level 3

Likes

22 likes

Total Posts

83 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Give Back
Ignite 1
Boost 5
Boost 3
View profile
sdouglasmc
Level 3

22-03-2020

I've installed the latest SP, 6.5.4 and now see the below error littered throughout the logs. Any quick fixes to get rid of this?

22.03.2020 19:11:00.158 *ERROR* [metrics-RRD4JReporter-1-thread-1] com.codahale.metrics.ScheduledReporter Exception thrown from RRD4JReporter#report. Exception was suppressed.
java.lang.IllegalStateException: RRD already closed, cannot store this sample
at org.rrd4j.core.RrdDb.store(RrdDb.java:512) [org.apache.sling.commons.metrics-rrd4j:1.0.2]
at org.rrd4j.core.Sample.update(Sample.java:194) [org.apache.sling.commons.metrics-rrd4j:1.0.2]
at org.apache.sling.commons.metrics.rrd4j.impl.RRD4JReporter.report(RRD4JReporter.java:260) [org.apache.sling.commons.metrics-rrd4j:1.0.2]
at com.codahale.metrics.ScheduledReporter.report(ScheduledReporter.java:235) [com.adobe.granite.dropwizard.metrics:3.2.4]
at com.codahale.metrics.ScheduledReporter$1.run(ScheduledReporter.java:174) [com.adobe.granite.dropwizard.metrics:3.2.4]
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
at java.base/java.util.concurrent.FutureTask.runAndReset(FutureTask.java:305)
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:305)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Boost 3
Level 1
scotty64724204
Level 1

Likes

3 likes

Total Posts

2 posts

Correct reply

1 solution
Top badges earned
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Boost 3
Level 1
scotty64724204
Level 1

Likes

3 likes

Total Posts

2 posts

Correct reply

1 solution
Top badges earned
Boost 3
Boost 1
Affirm 1
View profile
scotty64724204
Level 1

01-05-2020

Restart your AEM instance and it should fix it

Answers (2)

Answers (2)

Avatar

Avatar
Boost 250
MVP
Nikhil-Kumar
MVP

Likes

251 likes

Total Posts

262 posts

Correct reply

38 solutions
Top badges earned
Boost 250
Validate 1
Ignite 3
Ignite 1
Give Back 5
View profile

Avatar
Boost 250
MVP
Nikhil-Kumar
MVP

Likes

251 likes

Total Posts

262 posts

Correct reply

38 solutions
Top badges earned
Boost 250
Validate 1
Ignite 3
Ignite 1
Give Back 5
View profile
Nikhil-Kumar
MVP

15-08-2020

Hey,

Try restarting the AEM instance and verify the changes.

Avatar

Avatar
Level 1
HeavyDevy
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile

Avatar
Level 1
HeavyDevy
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile
HeavyDevy
Level 1

17-04-2020

I have the same Issue. Did you find out how to solve this? 

Fresh AEM 6.5.0 SP4 installed via Package Share.