Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Import package version mismatch problem after upgrading to AEM 6.5

Alisahali
Level 2
Level 2

Hello there,

I've run into an import package version mismatch problem in cq-wcm-foundation bundle after performing an in place upgrade to 6.5. Please read the notes below for more details:

1. Note that this error occurs right when I start my author instance for the first time. It can't be related to dependencies in my project or the uber-jar since I hadn't build it until this point

2. Also, note that the package isn't missing. I can see the package com.day.cq.wcm.api (version 1.28) being exported by bundle cq-wcm-api. However, cq-wcm-foundation expects a different version lower than 1.28

3. I could manually resolve the issue by uploading the cq-wcm-foundation bundle (that expects 1.28) from the previous 6.4 instance to get it working

4. We're currently resorting to uploading these bundles via a crx package after the upgrade has been performed to get the bundle and other dependent bundles to be active

 

However, I'd like to know if I'm missing anything. Perhaps a service pack by Adobe that can potentially fix it. I've thoroughly followed all the steps systematically as given in Adobe's documentation. Any pointers would be great. Thanks so much!! 

1 Accepted Solution
kalyan_maverick
Correct answer by
Level 3
Level 3

Hi @Alisahali 

as per my understanding your project contains core wcm components which requires aem version more than 6.5

try installing any service pack. higher than 6.5.7 (my suggestion would be 6.5.9.1) which is stable and support even the latest core wcm components.

you need to wait for minimum 3min after the service pack installation is complete. as it takes more than 3min to install all the components and required services in aem. so keep you page idle for min 3min after the installation is completed.

hope this fix your issue.

thank

 

View solution in original post

3 Replies
kalyan_maverick
Correct answer by
Level 3
Level 3

Hi @Alisahali 

as per my understanding your project contains core wcm components which requires aem version more than 6.5

try installing any service pack. higher than 6.5.7 (my suggestion would be 6.5.9.1) which is stable and support even the latest core wcm components.

you need to wait for minimum 3min after the service pack installation is complete. as it takes more than 3min to install all the components and required services in aem. so keep you page idle for min 3min after the installation is completed.

hope this fix your issue.

thank

 

Alisahali
Level 2
Level 2

@kalyan_maverick Thanks so much for answering. We ended up using a more recent version i.e 6.5.11.0 in accordance with our security guidelines. However, I reckon the version you suggested should have worked just fine too.