Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

I have created a new project in AEM 6.5 and getting bundle installed status on the OSGi web console.

Ameen_Dev
Level 1
Level 1

I am getting this error after creating a new project in AEM 6.5

 

Below are the errors

 

com.day.cq.wcm.api,version=[1.27,2) -- Cannot be resolved
org.apache.sling.api.resource,version=[2.11,3) -- Cannot be resolved
org.apache.sling.api.servlets,version=[2.2,3) -- Cannot be resolved
org.apache.sling.models.annotations,version=[1.5,2) -- Cannot be resolved

 

 

I thought of changing the dependencies version but I didn't find the dependencies in the POM file. So I added the dependency manually and saved the POM file.

Now how do I update the entire project and how to solve this issue? Please help me

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution
Asutosh_Jena_
Correct answer by
Community Advisor
Community Advisor

Hi @Ameen_Dev 

 

Please install AEM 6.5.8.0 service pack on your AEM instance and this issue will be resolved.

Can be downloaded from Adobe Software Distribution here if you have access to it.

https://experience.adobe.com/#/downloads/content/software-distribution/en/aem.html?package=/content/...

 

Service Pack 9 is the latest which is released on 2021-16-06 and I will not suggest to go for it as it might not be stable.

Let me know if you are not able to download from above link and I can share the google drive link.

 

Thanks!

View solution in original post

12 Replies
Asutosh_Jena_
Correct answer by
Community Advisor
Community Advisor

Hi @Ameen_Dev 

 

Please install AEM 6.5.8.0 service pack on your AEM instance and this issue will be resolved.

Can be downloaded from Adobe Software Distribution here if you have access to it.

https://experience.adobe.com/#/downloads/content/software-distribution/en/aem.html?package=/content/...

 

Service Pack 9 is the latest which is released on 2021-16-06 and I will not suggest to go for it as it might not be stable.

Let me know if you are not able to download from above link and I can share the google drive link.

 

Thanks!

View solution in original post

Ameen_Dev
Level 1
Level 1
I am able to download from the above link kindly share the google drive link
Ameen_Dev
Level 1
Level 1

@Asutosh_Jena_ After uploading the package! I am getting this Error. HTTP ERROR 404 Not Found URI: / STATUS: 404 MESSAGE: Not Found SERVLET: org.apache.felix.http.base.internal.dispatch.DispatcherServlet-12b4b41d

Asutosh_Jena_
Community Advisor
Community Advisor

HI @Ameen_Dev Typically installation takes some 5-6 min time. After installation you need to restart the instance. Did you try these steps?

Ameen_Dev
Level 1
Level 1

Yes, I tried restarting the instance and system as well but nothing worked. And I checked the bundle section, some of the bundle's status shows as Installed instead of active.

Asutosh_Jena_
Community Advisor
Community Advisor
Let me know if you would like to connect on a call and debug?
Bhuwan_B
Community Advisor
Community Advisor

@Ameen_Dev Please Cross check if Uber jar entry is in par with the AEM instance version you are using and then upgrade your Service Pack

Reference:

https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/com-day-cq-wcm-api-cannot-...

Ameen_Dev
Level 1
Level 1

@Bhuwan_B Where I need to go to check the version of the Uber jar entry and AEM version? Could you please guide me?