How do I determine the Oak version I use with my AEM installation?

Avatar

Avatar

anthogom

Avatar

anthogom

anthogom

30-03-2016

I'm reading the section "Offline Compaction" on this page:

  https://docs.adobe.com/docs/en/aem/6-0/deploy/upgrade/microkernels-in-aem-6-0.html

It cautions, "Different versions of the Oak-run tool need to be used depending on the Oak version you use with your AEM installation."

How do I determine the Oak version I use with my AEM installation?

View Entire Topic

Avatar

Avatar

tim-dunham

Avatar

tim-dunham

tim-dunham

28-02-2020

In the newest AEM documentation it states "use the version of Oak-run that matches the Oak core of your AEM installation"

The most reliable way to do that is to perform the following:

  1. Navigate to /system/console/bundles
  2. Filter by org.apache.jackrabbit.oak-core
  3. The version will be listed clearly

Oak Coreorg.apache.jackrabbit.oak-core
Symbolic Name org.apache.jackrabbit.oak-core
Version 1.6.11
Bundle Location launchpad:resources/install.crx3/15/oak-core-1.6.1.jar

.....