Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

FelixStart level issue after deploying project into author

Avatar

Level 4

Hi,

I created a project with this cmnd 
mvn -B archetype:generate
-D archetypeGroupId=com.adobe.aem
-D archetypeArtifactId=aem-project-archetype
-D archetypeVersion=26
-D appTitle="WKND SPA React"
-D appId="wknd-spa-react"
-D artifactId="aem-guides-wknd-spa.react"
-D groupId="com.adobe.aem.guides.wkndspa.react"
-D frontendModule="react"
-D aemVersion="6.5.11.0"
 
then after I deployed it to aem instance then i am getting the below error 
 
 *ERROR* [FelixStartLevel] com.adobe.granite.workflow.console bundle com.adobe.granite.workflow.console:1.0.118.CQ650-B0004 (295)[com.adobe.granite.workflow.console.publish.WorkflowPublishEventService(1015)] : The deactivate method has thrown an exception (java.lang.NullPointerException)
java.lang.NullPointerException: null
    at com.adobe.granite.workflow.console.publish.WorkflowPublishEventService.deactivate(WorkflowPublishEventService.java:123) [com.adobe.granite.workflow.console:1.0.118.CQ650-B0004]
    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.base/java.lang.reflect.Method.invoke(Method.java:566)
    at org.apache.felix.scr.impl.inject.methods.BaseMethod.invokeMethod(BaseMethod.java:242) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.inject.methods.BaseMethod.access$500(BaseMethod.java:41) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.inject.methods.BaseMethod$Resolved.invoke(BaseMethod.java:678) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.inject.methods.BaseMethod.invoke(BaseMethod.java:524) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.inject.methods.ActivateMethod.invoke(ActivateMethod.java:318) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.inject.methods.ActivateMethod.invoke(ActivateMethod.java:308) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.manager.SingleComponentManager.disposeImplementationObject(SingleComponentManager.java:409) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.manager.SingleComponentManager.deleteComponent(SingleComponentManager.java:164) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.manager.AbstractComponentManager.doDeactivate(AbstractComponentManager.java:832) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.manager.AbstractComponentManager.deactivateInternal(AbstractComponentManager.java:806) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.manager.AbstractComponentManager.dispose(AbstractComponentManager.java:585) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.manager.ConfigurableComponentHolder.disposeComponents(ConfigurableComponentHolder.java:717) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.BundleComponentActivator.dispose(BundleComponentActivator.java:532) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.Activator.disposeComponents(Activator.java:609) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.Activator.access$300(Activator.java:69) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.Activator$ScrExtension.destroy(Activator.java:452) [org.apache.felix.scr:2.1.20]
    at org.apache.felix.scr.impl.AbstractExtender$1.run(AbstractExtender.java:216) [org.apache.felix.scr:2.1.20]
    at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
    at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
   
Can anyone help me to fix this.
 
Thanks,
Vani.
 
1 Accepted Solution

Avatar

Correct answer by
Community Advisor

HI @Vani1012 

 

I see that you have raised another query after this issue with the same command to create the project: https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/service-factory-returning-...

 

Can you please close this if this is resolved?

 

Thanks,

Kiran Vedantam.

View solution in original post

2 Replies

Avatar

Correct answer by
Community Advisor

HI @Vani1012 

 

I see that you have raised another query after this issue with the same command to create the project: https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/service-factory-returning-...

 

Can you please close this if this is resolved?

 

Thanks,

Kiran Vedantam.

Avatar

Employee Advisor

@Vani1012  looks like duplicate question of td-p/453645.
Please close this one and use the thread linked above.

Thanks,

Milind