Error - org.apache.sling.api.servlets cannot be resolved

Avatar

Avatar

harishred

Avatar

harishred

harishred

16-03-2020

Hello all, trying to build my project and getting below error in my OSGi after deploying it as a bundle... (Project created by archetype 23).. I am seeing below error:

org.apache.sling.api.servlets,version=[2.3,3) -- Cannot be resolved

I have this dependency added in my POM

 

<dependency>
    <groupId>org.apache.sling</groupId>
    <artifactId>org.apache.sling.api</artifactId>
    <version>2.3.0</version>
    <scope>provided</scope>
</dependency>

 

Tried all versions https://repo.adobe.com/nexus/content/groups/public/org/apache/sling/org.apache.sling.api/ but no luck. What am I missing?

 

Error from logs:

14.03.2020 22:36:12.200 *ERROR* [qtp1524159769-1650] org.apache.felix.http.jetty %bundles.pluginTitle: Cannot start (org.osgi.framework.BundleException: Unable to resolve akamdashapi.core [585](R 585.1): missing requirement [akamdashapi.core [585](R 585.1)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.api.servlets)(version>=2.3.0)(!(version>=3.0.0))) Unresolved requirements: [[akamdashapi.core [585](R 585.1)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.api.servlets)(version>=2.3.0)(!(version>=3.0.0)))])
org.osgi.framework.BundleException: Unable to resolve akamdashapi.core [585](R 585.1): missing requirement [akamdashapi.core [585](R 585.1)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.api.servlets)(version>=2.3.0)(!(version>=3.0.0))) Unresolved requirements: [[akamdashapi.core [585](R 585.1)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.api.servlets)(version>=2.3.0)(!(version>=3.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)

@kautuk_sahni @Jörg_Hoh @Arun_Patidar 

 

AEM 6.5 applets osgi sling

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

chrisatsirius

Avatar

chrisatsirius

chrisatsirius

18-03-2020

get service pack 4(6.5.4), it should fix your issue.

 

Answers (2)

Answers (2)

Avatar

Avatar

Arun_Patidar

MVP

Total Posts

2.9K

Likes

1.0K

Correct Answer

831

Avatar

Arun_Patidar

MVP

Total Posts

2.9K

Likes

1.0K

Correct Answer

831
Arun_Patidar
MVP

18-03-2020

Can you check what version of org.apache.sling.api.servlets you have in aem.

You can check using /system/console/depfinder

 

In AEM 6.5 It is 2.2.1

 

Please check https://stackoverflow.com/questions/20278236/org-apache-sling-api-resource-version-2-3-3-cannot-be-r...

 

Avatar

Avatar

Vijayalakshmi_S

MVP

Avatar

Vijayalakshmi_S

MVP

Vijayalakshmi_S
MVP

16-03-2020

Hi,

 

Please look for the "Exported Packages" list of the bundle - Apache Sling API (org.apache.sling.api) in your instance.

We will have the servlets API mentioned with version as one among the list.

  • Make an entry of the same explicitly in the "Import-Package" list of bundle plugin in core/pom.xml

Also, the maven dependency to be added can be arrived at using system/console/depfinder.html which will be  - the whole of sling API bundle that exposes the servlets API.

sling-api-servlets.png