Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

CQ-MSM-LOCKABLES not working only on PROD environment

Avatar

Level 1

Hello All,

 

We are experiencing an issue related to cq-msm-lockables only on PROD environment. The inheritance chain icons are not coming for any of the page properties (In live-copies).

 

The same is working on other local environments like DEV/STAGE and even on local vanilla instances as well.

 

Did anyone experienced similar kind of issue?

 

** AEM Version 6.5.9-1

** No errors in console as well as in error logs

** Inheritance functionality is working only the chain icons corresponding to the page properties is not coming.

 

Any pointers on this would be really appreciated!!

Thanks in Advance!!

 

Regards,

Tanika

1 Accepted Solution

Avatar

Correct answer by
Level 10

Hi @TanikaAggarwalAEM ,

Looks like the inheritance relation is corrupted on the server. More root cause can be figured out by checking the logs for the time since the issue started. 

To fix the issue, you can re enable the live copy relationship and it should inherit from the blueprint.

Refer to this link if it helps in debugging:

 

https://sourcedcode.com/blog/aem/how-to-re-sync-a-live-copy-language-root-to-a-blueprint-in-aem-msm

 

View solution in original post

1 Reply

Avatar

Correct answer by
Level 10

Hi @TanikaAggarwalAEM ,

Looks like the inheritance relation is corrupted on the server. More root cause can be figured out by checking the logs for the time since the issue started. 

To fix the issue, you can re enable the live copy relationship and it should inherit from the blueprint.

Refer to this link if it helps in debugging:

 

https://sourcedcode.com/blog/aem/how-to-re-sync-a-live-copy-language-root-to-a-blueprint-in-aem-msm