Assets included via components are not appearing from Publisher

Avatar

Avatar

learner_monk

Avatar

learner_monk

learner_monk

26-04-2020

Hi Team,

 

I just created a brand new AEM project (referring to WKND Tutorial) and created one template, component and few sample pages. I have used my custom component along with few out of box core component to create pages.

After creating pages in author I tried “View as Published Page” option and everything looks good.

 

Once done, I started a brand new publisher instance on another port and installed newly created project on publisher instance. After installation of package on publisher I am noticing that assets referred via any of components, out of box or the custom is not appearing on page.

 

I verified and could see the node present from CRXDE of publisher and even logged in as admin to publisher to rule out any access conflict.

 

1102 TIMER_END{80,ResourceResolution} URI=/language-masters/en/myproject/abcdPage/_jcr_content/root/responsivegrid_2041874655/responsivegrid_1344640622/carousel/item_1587246455642.coreimg.png/1587841266885/carousel-replace-02.png resolves to Resource=NonExistingResource, path=/language-masters/en/myproject/abcdPage/jcr:content/root/responsivegrid_2041874655/responsivegrid_1344640622/carousel/item_1587246455642.coreimg.png/1587841266885/carousel-replace-02.png

 

I can see the assets for sample we retail pages referred in same way.

 

URI=/content/we-retail/us/en/_jcr_content/root/responsivegrid/carousel/teaser.coreimg.jpeg/1550495490312/running-woods-woman.jpeg resolves to Resource=JcrNodeResource, type=weretail/components/content/teaser, superType=null, path=/content/we-retail/us/en/jcr:content/root/responsivegrid/carousel/teaser

 

 

Please suggests, not sure what I am missing here.

Thanks!

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

learner_monk

Avatar

learner_monk

learner_monk

26-04-2020

My bad..I realized after posting my question that initial root node - /content/WXYZ is missing for asset URL.

 

It seems by default project created JCR Resource Resolver Factory with mapping config and i have different root path for dam and sites pages.

Answers (0)