Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM 6.5 SP 10 installation

subrato_kha
Level 4
Level 4

Hi All,

We are trying to upgrade AEM 6.5.5 to the latest version of AEM 6.5 service pack(sp10). After installation of service pack when we restart the instance the instance fails to restart with all bundles fails to start error in the stdout.log file. We are using AME 6.5.5 with java 8. It is only happening on our EC2 instances. It works fine on local macbook.

 

Has anyone faced this issue.

below is some of the stdout.log 

 

11.11.2021 10:43:31.777 *ERROR* [FelixStartLevel] ERROR: Bundle '1' Error starting slinginstall:org.apache.sling.installer.factory.configuration-1.1.2.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.factory.configuration [1](R 1.3): missing requirement [org.apache.sling.installer.factory.configuration [1](R 1.3)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api)(version>=3.2.0)(!(version>=4.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [7](R 7.2): missing requirement [org.apache.sling.installer.core [7](R 7.2)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [6](R 6.1): missing requirement [slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [16](R 16.4): missing requirement [org.apache.sling.commons.log [16](R 16.4)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]]] Unresolved requirements: [[org.apache.sling.installer.factory.configuration [1](R 1.3)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api)(version>=3.2.0)(!(version>=4.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.factory.configuration [1](R 1.3): missing requirement [org.apache.sling.installer.factory.configuration [1](R 1.3)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api)(version>=3.2.0)(!(version>=4.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [7](R 7.2): missing requirement [org.apache.sling.installer.core [7](R 7.2)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [6](R 6.1): missing requirement [slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [16](R 16.4): missing requirement [org.apache.sling.commons.log [16](R 16.4)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]]] Unresolved requirements: [[org.apache.sling.installer.factory.configuration [1](R 1.3)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api)(version>=3.2.0)(!(version>=4.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)
11.11.2021 10:43:31.784 *ERROR* [FelixStartLevel] ERROR: Bundle '3' Error starting slinginstall:org.apache.sling.settings-1.3.8.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.settings [3](R 3.1): missing requirement [org.apache.sling.settings [3](R 3.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [6](R 6.1): missing requirement [slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [16](R 16.4): missing requirement [org.apache.sling.commons.log [16](R 16.4)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[org.apache.sling.settings [3](R 3.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.settings [3](R 3.1): missing requirement [org.apache.sling.settings [3](R 3.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [6](R 6.1): missing requirement [slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [16](R 16.4): missing requirement [org.apache.sling.commons.log [16](R 16.4)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[org.apache.sling.settings [3](R 3.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)

11.11.2021 10:43:31.796 *ERROR* [FelixStartLevel] ERROR: Bundle '6' Error starting slinginstall:slf4j-api-1.7.21.jar (org.osgi.framework.BundleException: Unable to resolve slf4j.api [6](R 6.1): missing requirement [slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [16](R 16.4): missing requirement [org.apache.sling.commons.log [16](R 16.4)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)] Unresolved requirements: [[slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))])
org.osgi.framework.BundleException: Unable to resolve slf4j.api [6](R 6.1): missing requirement [slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [16](R 16.4): missing requirement [org.apache.sling.commons.log [16](R 16.4)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)] Unresolved requirements: [[slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)
11.11.2021 10:43:31.800 *ERROR* [FelixStartLevel] ERROR: Bundle '7' Error starting slinginstall:org.apache.sling.installer.core-3.8.6.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.core [7](R 7.2): missing requirement [org.apache.sling.installer.core [7](R 7.2)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [6](R 6.1): missing requirement [slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [16](R 16.4): missing requirement [org.apache.sling.commons.log [16](R 16.4)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[org.apache.sling.installer.core [7](R 7.2)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.core [7](R 7.2): missing requirement [org.apache.sling.installer.core [7](R 7.2)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [6](R 6.1): missing requirement [slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [16](R 16.4): missing requirement [org.apache.sling.commons.log [16](R 16.4)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[org.apache.sling.installer.core [7](R 7.2)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)
11.11.2021 10:43:31.816 *ERROR* [FelixStartLevel] ERROR: Bundle '10' Error starting slinginstall:com.adobe.granite.crypto-3.4.8.jar (org.osgi.framework.BundleException: Unable to resolve com.adobe.granite.crypto [10](R 10.1): missing requirement [com.adobe.granite.crypto [10](R 10.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.6)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [6](R 6.1): missing requirement [slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [16](R 16.4): missing requirement [org.apache.sling.commons.log [16](R 16.4)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[com.adobe.granite.crypto [10](R 10.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.6)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve com.adobe.granite.crypto [10](R 10.1): missing requirement [com.adobe.granite.crypto [10](R 10.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.6)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [6](R 6.1): missing requirement [slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [16](R 16.4): missing requirement [org.apache.sling.commons.log [16](R 16.4)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[com.adobe.granite.crypto [10](R 10.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.6)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)
11.11.2021 10:43:31.820 *ERROR* [FelixStartLevel] ERROR: Bundle '11' Error starting slinginstall:org.apache.sling.commons.logservice-1.0.6.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.logservice [11](R 11.0): missing requirement [org.apache.sling.commons.logservice [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [6](R 6.1): missing requirement [slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [16](R 16.4): missing requirement [org.apache.sling.commons.log [16](R 16.4)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[org.apache.sling.commons.logservice [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.logservice [11](R 11.0): missing requirement [org.apache.sling.commons.logservice [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [6](R 6.1): missing requirement [slf4j.api [6](R 6.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [16](R 16.4): missing requirement [org.apache.sling.commons.log [16](R 16.4)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[org.apache.sling.commons.logservice [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)

 

@Jörg_Hoh

5 Replies
Asutosh_Jena_
Community Advisor
Community Advisor

Hi @subrato_kha 

 

You are getting this error as multiple dependencies are not getting resolved after upgrading to 6.5.10.0 version.

 

To fix this you will need to upgrade the uber jar version on your project POM to 6.5.10

 

<dependency>
     <groupId>com.adobe.aem</groupId>
     <artifactId>uber-jar</artifactId>
     <version>6.5.10</version>
     <scope>provided</scope>
</dependency>

 

The UberJar for Experience Manager 6.5.10.0 is available in the Maven Central repository.

 

Thanks!

subrato_kha
Level 4
Level 4

Hi @Asutosh_Jena_ ,
I am using 6.5.10 uber jar in my project. The AEM itself is not starting post upgrade after restart of the instance.

ManuMathew1994
Level 4
Level 4

Hi @subrato_kha 

Did you try creating a new .m2 repository build for the same, by either renaming or deleting the existing .m2 repository?

subrato_kha
Level 4
Level 4

Hi @ManuMathew1994,

 

The instance itself is not starting can you explain how I would be able to install my package with new .m2 repository?