AEM 6.5 Solr integration issue

Avatar

Avatar

binoyp

Avatar

binoyp

binoyp

25-05-2020

Hi All,

 

The http://localhost:4502/etc/solr/solrindexer.html url opens up an empty page when checked in aem 6.5.

However, this is working in version 6.4. Couldnt find a more recent article on integration with 6.5

Could anyone advice on this issue ?

Reference :https://helpx.adobe.com/experience-manager/using/aem_solr64.html

AEM Solr

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Shashi_Mulugu

MVP

Avatar

Shashi_Mulugu

MVP

Shashi_Mulugu
MVP

30-05-2020

Best thing is create a new project from latest AEM maven archetype and start copy pasting code as needed from the integration post along with pom dependencies..

 

If you want to upgrade, start comparing dependencies version from newly created project vs the post

Ex: uberjar which is 6.3.0 in that post, to run on 6.5 you need 6.5.0 or more etc..

Answers (2)

Answers (2)

Avatar

Avatar

PuzanovsP

MVP

Avatar

PuzanovsP

MVP

PuzanovsP
MVP

26-05-2020

Hey Bino,

 

This article has been created and tested on AEM 6.4.

 

If you want to use this code in 6.5 you need to perform upgrade of this demo code from 6.4 to 6.5 then it would work.

 

Regards,

Peter

Avatar

Avatar

anjabed

Avatar

anjabed

anjabed

09-06-2020

Hi, 
we had the same problem in 6.5 but it also exists in 6.4 until SP4 with the example code from documentation.

 

Can you please describe how you fixed it because the marked answer I do not understand because ueber.jar in 6.4 is the same as in 6.4.4. The difference is that the page is white in 6.4.4 but works in 6.4.3.

 

Hope you can help me.