Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.5.6/Day CQ Linkchecker +Handlebars: a/link tag is getting stripped

jayv25585659
Level 6
Level 6

As above. When I looked at the rendered HTML, the <a> tag is missing completely.

This is my HTML code:

 

 

<h3>{{PRODUCT_CATEGORY}}</h3>
<h3><a href="{{PRODUCT_URL}}" x-cq-linkchecker=“valid”>MY LINK HERE</a></h3>

 

 

I looked at the logs and the error is because of the linkchecker service

 

com.day.cq.rewriter.linkchecker.impl.LinkCheckerImpl Ignoring malformed URI

 

This should not be a problem (theoretically) because I followed all the 3 suggestions on this page: https://experienceleague.adobe.com/docs/experience-cloud-kcs/kbarticles/KA-16563.html?lang=en

  1. I added x-cq-linkchecker=“valid” in my link tag. As a test, I tried "valid" and "skip". I got the same result.
  2. I disabled link checking in Day CQ Link Checker Transformer service
  3. Added ^ to the Link checker override patternsAD

additional info:

  1. localhost:4502/etc/linkchecker.html has no entries/records
  2. Day CQ Link Checker Task/Scheduler Period = 3600 seconds (though I do not this should matter since I supposedly disabled link checking?)


Screen Shot 2021-07-15 at 1.39.45 PM.png

Screen Shot 2021-07-15 at 1.37.45 PM.png

Screen Shot 2021-07-15 at 4.08.15 PM.png

 

1 Accepted Solution
snbaem
Correct answer by
Community Advisor
Community Advisor

Hi,

 

Can you try to update the Link Checked Transformer and check?

snbaem_0-1626449216726.png

Also try to delete the config, reload and save the desired config again?
For me just Checking the "Disable Checking" checkbox helps. AEM 6.5.8

View solution in original post

3 Replies
Dipti_Chauhan
Community Advisor
Community Advisor

Hi

  Can you check when link was last validated (/etc/linkchecker.html). And also check link checker service scheduler frequency .May be this link is yet to be scanned.

 

Thanks

Dipti Chauhan

jayv25585659
Level 6
Level 6
Thank you for the reply. I just edited my original post with additional information.
snbaem
Correct answer by
Community Advisor
Community Advisor

Hi,

 

Can you try to update the Link Checked Transformer and check?

snbaem_0-1626449216726.png

Also try to delete the config, reload and save the desired config again?
For me just Checking the "Disable Checking" checkbox helps. AEM 6.5.8

View solution in original post