Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Get Permissions API failing

satsukitv
Level 1
Level 1

The response from https://authorization.publish.adobe.io/permissions/ is:

{ code: '4002',

  message: 'Parameter [X-GW-IMS-User-Email] is empty or null.' }

Including a header or get query with that parameter has no effect. The request has all the headers necessary according to the documentation and example.

{ 'X-DPS-Client-Version': '0.0.1',

     'X-DPS-Client-Id': 'CLIENT_ID',

     'X-DPS-Client-Request-Id': '2a76a3c6-4946-4d8b-9926-5ff8670cc89b',

     'X-DPS-Client-Session-Id': '8eb48262-0541-4c89-a7e0-63216c53d441',

     'X-DPS-Api-Key': 'CLIENT_ID',

     Accept: 'application/json',

     'X-GW-IMS-User-Email': 'USER@EMAIL.COM',

     Authorization: 'bearer REDACTEDACCESSTOKEN' }



Any idea what this error means and how to tackle it?


1 Accepted Solution
AndreiParaschiv
Correct answer by
Employee
Employee

Hi,

The parameter in your request ("X-GW-IMS-User-Email") isn't part of the documentation or the sample code provided in the article : Digital Publishing Solution Help | Integrating with Adobe Digital Publishing Solution

Please make sure that you have all the elements as follows :

https://ims-na1.adobelogin.com/ims/token/v1?grant_type=device&client_id=your_client_ID&client_secret=your_client_secret&scope=AdobeID%2Copenid&device_token=your_device_token&device_id=your_device_id

You can run the sample code provided in article mentioned above which will assure that you are running everything in the right direction.

In case the problem persists, please send a mail to wwds@adobe.com

Thanks,

Andrei

View solution in original post

1 Reply
AndreiParaschiv
Correct answer by
Employee
Employee

Hi,

The parameter in your request ("X-GW-IMS-User-Email") isn't part of the documentation or the sample code provided in the article : Digital Publishing Solution Help | Integrating with Adobe Digital Publishing Solution

Please make sure that you have all the elements as follows :

https://ims-na1.adobelogin.com/ims/token/v1?grant_type=device&client_id=your_client_ID&client_secret=your_client_secret&scope=AdobeID%2Copenid&device_token=your_device_token&device_id=your_device_id

You can run the sample code provided in article mentioned above which will assure that you are running everything in the right direction.

In case the problem persists, please send a mail to wwds@adobe.com

Thanks,

Andrei

View solution in original post