Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

How to send evar and props in place of context data for iOS Mobile App in v4.4 ADBMobile.h

dev_dev
Level 1
Level 1

Hi,

I migrating to the latest version of analytics library v4.4. I am not able to find a method to track an event with variables.

- (void)trackWithContextData:(NSDictionary *)contextData variables:(NSDictionary *)variables;

It seems like in 4.4v, there is no support for variables evars and props.

My client haven't provided Context data values, all i am having is the evars and props. 

I am doing an update to my existing version of the app. I cant afford any changes to existing analytics integration.

The reason behind my migration is to support 64 bit. I need a version which has 64 bit support and track events with variables not context data

1 Accepted Solution
brian_au
Correct answer by
Level 9
Level 9

Hi,

I can confirm in the Adobe Mobile Analytics 4.x SDK there is no longer support for explicit setting of variables and you must use context variables. A detailed overview on the topic and how to set events with context data is linked below:

http://blogs.adobe.com/digitalmarketing/digital-marketing/context-data-adobe-mobile-analytics-change...

Best,

Brian

View solution in original post

3 Replies
brian_au
Correct answer by
Level 9
Level 9

Hi,

I can confirm in the Adobe Mobile Analytics 4.x SDK there is no longer support for explicit setting of variables and you must use context variables. A detailed overview on the topic and how to set events with context data is linked below:

http://blogs.adobe.com/digitalmarketing/digital-marketing/context-data-adobe-mobile-analytics-change...

Best,

Brian

View solution in original post

dev_dev
Level 1
Level 1

Thanks Brain. Yes after some browsing able to figured it out. In 3.x series, version 3.3.0 got 64 bit support. Can you please help me out, How to get version 3.3.0. There is an unofficial git upto 3.1.16. and Cocoapods for 4.x.

Thanks,
Satya

brian_au
Level 9
Level 9

Hi Satya,

I do not have access to version 3.3 of the SDK. I would recommend trying to reach out to Adobe Customer Care.

Best,

Brian