Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

shubham250894
Community profile shubham250894 Level 1
Job title here
Location here
4 BADGES
Level 1

Level 1

Learn more
Joined the community 04-06-2017 8:57:15 PM
Offline
Top badges earned by shubham250894
Customize the badges you want to showcase on your profile
Re: OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager
Thanks Feike, I hope you would not mind to help me in future also with your help, i am able to figure out the issue , Thanks alot

Views

1.0K

Like

1

Replies

0
Re: OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager
I made the blunder there is issue with the highlighted import i changed it to import org.apache.felix.scr.annotations.Component; and it works fine. Thanks for the help everyone

Views

1.0K

Likes

0

Replies

0
Re: OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager
Yes there is no MyServiceImpl but Why ?

Views

1.0K

Likes

0

Replies

0
Re: OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager

Views

1.0K

Likes

0

Replies

0
Re: OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager
yeah the service is null

Views

1.0K

Likes

0

Replies

0
Re: OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager

Views

1.0K

Likes

0

Replies

0
Re: OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager
Hi Veena,I got this in error log. Red marked logs says it is registered. in error log i cannot find my service at all

Views

1.0K

Likes

0

Replies

0
Re: OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager
Hi Veena,I cannot see anything like conflicting service in error log, should i give you the screenshot of the logs created after reloading the page ?

Views

1.0K

Likes

0

Replies

0
Re: OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager
hi cquser1,thanks for your concern but it didn't worked

Views

1.0K

Likes

0

Replies

0
Re: OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager
hi smacdonald,Thanks for the help

Views

1.0K

Likes

0

Replies

0
Re: OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager
yes bundle is started, Also, i can find my package name in MANIFEST info.

Views

1.0K

Likes

0

Replies

0
Re: OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager
I can only see the below services,the service i created is not there, hence it is giving null pointer exception

Views

1.0K

Likes

0

Replies

0
Re: OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager
sorry , here is the bundle screenshot, JSP screenshot and null pointer exceptionJSPException,Bundle

Views

1.0K

Likes

0

Replies

0
OSGI srvice is not getting registered
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager
Hi,I am facing an issue i created a project of maven archType10 in eclipse and when i upload the bundle on felix console it does not show the service registered over there below is the code what i wrote and screenshot of the bundle on felix,MyService.java (Interface)package com.aem.community.core.services;public interface MyService { public String helloWorld();}MyServiceImpl.java (class implementing Interface)package com.aem.community.core.servicesImpl;import org.apache.felix.scr.annotations.Ser...

Views

6.4K

Likes

2

Replies

24
Re: AEM is not starting
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager Forms
Thanks @Jorg i searched the port number string in log it showed the result, and the loopback link "http://127.0.0.1:4502/​" also was not working, but thanks for the help

Views

2.0K

Likes

0

Replies

0
Re: AEM is not starting
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager Forms
Thanks @shiju for the concern but changing proxy settings worked for me, as i am working office network so no admin rights is there

Views

1.6K

Likes

0

Replies

0
Re: AEM is not starting
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager Forms
Thanks

Views

1.6K

Likes

0

Replies

0
Re: AEM is not starting
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager Forms
I am not even able to hit the login page of AEM, and i am not able to find anything suspicious in error.log,Later i realized that i am able to work in explorer but not in chrome so i got ip of my system and from that i accessed AEM (:4502) but not when i hit localhost:4502, Why so?

Views

1.6K

Likes

0

Replies

0
AEM is not starting
Avatar
Validate 1
Level 1
shubham250894
Level 1

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
shubham250894
- Adobe Experience Manager Forms
I started the AEM author instance by the start.bat ( crx-quickstart > bin > start.bat ), there the server is showing the startup complete but when i am hitting on link localhost:4502 it is showing connection refused ??

Views

7.4K

Likes

0

Replies

9
Likes given to
Likes from