Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

sandeepv5710160
Community profile sandeepv5710160 Level 3
Job title here
Location here
12 BADGES
Level 3

Level 3

Learn more
Joined the community 19-01-2017 9:44:31 AM
Offline
Top badges earned by sandeepv5710160
Customize the badges you want to showcase on your profile
Re: is it possible to upload more than 1 cert in Global Trust store ?
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Yes you could add more than 1 cert in truststore we had salesforce apps and we have added 2 different certificate for those saml configs

Views

32

Like

1

Replies

0
Re: Salesforce connection issue from AEM
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Thanks smacdonald2008​, but after the suggested changes of updating default authorization URL value also we are facing same issue.

Views

241

Likes

0

Replies

0
Salesforce connection issue from AEM
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Hello All,We have SFDC integration with AEM and while establishing connection we are getting below error even all the connection info are correct,any hints are help on enabling logs to capture what info being posted to SFDC will be helpful to us to debug/troubleshoot this issue.Thanks in advanceError in Getting Access Token: invalid_client

Views

463

Likes

0

Replies

3
Re: SAML Redirection issue in AEM 6.2
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Hi NaveenURL encoding on SAML_REQUEST_PATH cookie helped us resolving the issue,follow below code to implement the same.package com.mycompany.myproject.impl;import org.apache.felix.scr.annotations.*;import org.apache.sling.api.resource.LoginException;import org.apache.sling.auth.core.AuthUtil;import org.apache.sling.auth.core.spi.AuthenticationInfo;import org.apache.sling.auth.core.spi.AuthenticationInfoPostProcessor;import org.slf4j.Logger;import org.slf4j.LoggerFactory;import javax.servlet.htt...

Views

398

Likes

0

Replies

0
Re: Jenkins Build Failure
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Settings.xml path was wrongly configured in Jenkins and issue is resolved after correcting it .. thanks all

Views

766

Likes

0

Replies

0
Re: Jenkins Build Failure
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
I had given credentials in Jenkins config

Views

497

Likes

0

Replies

0
Jenkins Build Failure
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Hi - I have a maven project and when i Trigger build from Jenkins, the build fails showing the below error message. [INFO] Installing Bundle core(/var/build/.jenkins/jobs/test_1/workspace/core/target/0.0.1-SNAPSHOT.jar) to Host:port/crx/repository/crx.default/apps/project/install/ via PUT [INFO] basic authentication scheme selected [INFO] Failure authenticating with BASIC 'Adobe CRX WebDAV'@host:portwaiting for Jenkins to finish collecting data[ERROR] Failed to execute goal org.apache.sling:mave...

Views

1.7K

Like

1

Replies

5
Re: OOTB Workflow inbox item is taking more time to load
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Hi Zeeshan,Thanks for the update,but I observed in our environment this values are already present, means there is already an AutoWorkflowPurge is running by default in all environments and we are using AEM 6.2Still the request is taking 7-8 seconds to load inbox list/libs/cq/workflow/content/inbox/list.json?_dc=1500634389165&start=0&limit=40&maxCount=40any other suggestions, also to mention we have monthly tar compaction which we ran today morning.Any alternate suggestion on any particular logs...

Views

291

Likes

0

Replies

0
Re: OOTB Workflow inbox item is taking more time to load
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
/libs/cq/workflow/content/inbox/list.json?_dc=1500634389165&start=0&limit=40&maxCount=40

Views

292

Likes

0

Replies

0
OOTB Workflow inbox item is taking more time to load
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
In one of the environment OOTB AEM Inbox is taking 8-10 sec to load,there were only 20 items in inbox and with even more count in other environments inbox is loading within a second. Any configuration update required to increase the performance is appreciable.We have cleared all the failed workflow instances.Thanks

Views

880

Likes

0

Replies

3
Re: Custom workflows are not loading in inbox after activation request
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
smacdonald2008​Thanks for the help here.Attached is the screenshot of workflow, this exception occurs at starting of the workflow.Means first step which dynamically assigns approver group based on country where user is activating content. public String getParticipant(WorkItem workItem, WorkflowSession wfSession, MetaDataMap metaDataMap) throws WorkflowException { LOGGER.info("####### Participant : " + this.CONTENT_APPROVAL_GROUP + " ##############"); Session jcrSession = (Session)wfSession.adapt...

Views

365

Likes

0

Replies

0
Custom workflows are not loading in inbox after activation request
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Hi All,We are in AEM 6.2 and getting below error when clicking on inbox after activation request. Currently inbox is empty any suggestion.2.06.2017 18:21:37.554 *ERROR* [196.3.50.254 [1498148497547] GET /libs/cq/workflow/content/inbox/list.json HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingExceptionjava.lang.NullPointerException: null at org.apache.jackrabbit.oak.jcr.delegate.AuthorizableDelegator.unwrap(AuthorizableDelegator.java:65) at org.apache.jackr...

Views

691

Likes

0

Replies

2
Tag ID xtype multifield issue in AEM 6.2
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
We have multifield tag as below.|- MultiField (ootb multifield ) |-fieldConfig - xtype : multifieldpanel |- field A (xtype:textfield example textfield) |- field B (xtype:pathfield example pathfield) |- field C (xtype:tags example tags field) Where tag field is not a mandatory field but when a tagfield doesn't contain any values all the pre entered values are getting disappeared from the dialog. ex: |- field A1 "Some text" |- field B1 "Some path" |- field C1 "" |- field A2 "Some text" |-...

Views

1.5K

Like

1

Replies

2
SAML_REQUEST_PATH is not getting cleared after logout(/system/sling/logout) in AEM 6.2
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Hello SAML_REQUEST_PATH is not getting cleared after logout(/system/sling/logout) in AEM 6.2 any pointers on how to create custom handler with method info will be helpful to clear the mentioned cookie or else if any one came across this issue and is there any hotfix available?Since the same functionality was working with AEM 6.0,SAML_REQUEST_PATH was getting cleared by OOTB implementation before.This logout issue is global means both in Author SSO and Publish/portal SAML login.Thanks for your he...

Views

457

Likes

0

Replies

0
Re: SAML Redirection issue in AEM 6.2
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Hi MC,Thanks for the update.I agree with your comments, could you please elaborate on thisYou need to fix at project level by using filter Or JS to take care of product change. Unfortunately OOB no config option. any references will be a great help for us.ThanksSandeep

Views

378

Likes

0

Replies

0
SAML Redirection issue in AEM 6.2
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
We have done an AEM 6.2 upgrade from AEM 6.0, post that any request to resource through SAML handler is redirecting to home page.for example : when resource request is for 'events' page like this is www.ex.com/system/sling/login?resource=/content/project/events.html it's redirecting to home page instead of requested resource.This was working in AEM 6.0.because of this none of the CUG pages are working since all the requested resource which are private content trigger /system/sling/login and redi...

Views

1.1K

Likes

0

Replies

5
Re: Audit log based on local user time zone in side kick
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Hi MC,Thanks for the lead,actually the JS mentioned above is been used to generate the dialog frame./libs/cq/ui/widgets/source/widgets/wcm/AuditLogDialog.jsBut the values are generated in the below mentioned JSP,I'm now able to acheive requirement with this./libs/foundation/components/primary/cq/Page/audit.json.jspThanks for the help.

Views

196

Likes

0

Replies

0
Re: Audit log based on local user time zone in side kick
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
+screesnshot

Views

189

Likes

0

Replies

0
Audit log based on local user time zone in side kick
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Audit log(screenshot attached) for a page is recording all creation and activation date and time info,but the timestamp being recorded is based on server time zone where AEM installed.We have a requirement to display time stamp based on local time/country which content editor is editing.Example any China page being activated and modified time stamp recorded in audit log on side kick needs to display log in Chinese time stamp.Is there any configuration needs to be done to acheive this.All inputs ...

Views

331

Like

1

Replies

3
EmailService of acs-aem-commons 3.2.0 sends plain text mail
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Hello We have an issue in our custom email service where the email sent using acs-aem-commons sendmail method is coming as a plain text even though we have a mail template as html.Any suggestion here to any configuration changes to fix this issue is highly appreciated and valued.We need mail to be sent with content-type as htmlThanks in advance

Views

208

Likes

0

Replies

0
Re: AEM 6.2 SAML Login issue
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Thank you all for the inputs .... Tagging issue got resolved post giving read access to system user to access /etc/tags/

Views

867

Likes

0

Replies

0
Re: AEM 6.2 SAML Login issue
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Thank you all for the interest .. Tagging issue got resolved post giving read access to system user to access /etc/tags/

Views

669

Likes

0

Replies

0
Re: AEM 6.2 SAML Login issue
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Hi MC,Thanks for your reply.We had further debugged the issue and found final TagManager tagmanager =getResourceResolver().adaptTo(TagManager.class);final Tag tag = tagmanager.resolve(tagName);tag information is throwing null,It's failing to resolve the tagid passed.not sure what has gone wrong we have correct tags which we were using in 6.0 is deployed in 6.2 and the same lines of code was working fine in 6.0Is there any changes required for the way we are getting tags required to get this work...

Views

672

Likes

0

Replies

0
Re: AEM 6.2 SAML Login issue
Avatar
Ignite 10
Level 3
sandeepv5710160
Level 3

Likes

4 likes

Total Posts

24 posts

Correct reply

2 solutions
Top badges earned
Ignite 10
Give Back 10
Ignite 5
Give Back 5
Give Back 3
View profile
sandeepv5710160
- Adobe Experience Manager
Hi Prince,Thanks for your help here.The exact issue here is when user is created post SAML authentication was created with a plain text below /home/users before upgrading to 6.0. But post upgrading same user is create with some encrypted way example: In 6.0 user is created in a way /home/users/sandeep.vishwanath@gmail.comIn 6.2 /home/users/Zskdfkdfdhfjjfdhdjfjd for the same user and email attribute of this user is saved as sandeep.vishwanath@gmail.com here we are using SFDC login id which is use...

Views

669

Likes

0

Replies

0
Likes given to
Likes from