Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

kishore_polsani
kishore_polsani
Offline

Badges

Badges
21

Accepted Solutions

Accepted Solutions
7

Likes

Likes
11

Posts

Posts
77

Discussions

Discussions
20

Questions

Questions
57

Ideas

Ideas
0

Blog Posts

Blog Posts
0
Top badges earned by kishore_polsani
Customize the badges you want to showcase on your profile
Re: UTF-8 characters returned from Search and Promote show garbled characters
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Any other tags which I can add in transport template to get rid of this charset issue. I tried this snippet in transport template.

Views

240

Likes

0

Replies

0
Re: UTF-8 characters returned from Search and Promote sho...
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Hi Albin, I have tried it already, but no luck

Views

336

Likes

0

Replies

0
Re: Default image URL in Adobe Search and Promote
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
I have below tag in presentation template. How can we add the default path here, and this default path should be added only if actual image URL is broken. <guided-result-field gsname="imageUrl" />

Views

395

Likes

0

Replies

0
UTF-8 characters returned from Search and Promote show garbled characters
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
When using Search and Promote integration with AEM, certain UTF-8 characters are returned in results (XML) as garbled characters. Text is visible correctly in Search and Promote data view report with proper UTF-8 encoding.I have added the charset as UTF-8 in both custom presentation and transport templates. Any idea why the text in XML response is not having proper encoding. TestPresentation.tmpl TestTransport.tpl

Views

359

Likes

0

Replies

3
Re: No results in Adobe Search and Promote XML response
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
I have created new guided.tpl (Transport template), and its working now, able to see the results in XML response

Views

399

Likes

0

Replies

0
Re: No results in Adobe Search and Promote XML response
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Yes, I have guided_xml.tmpl

Views

416

Likes

0

Replies

0
No results in Adobe Search and Promote XML response
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
I can see indexed data in Reports -> Data view, when I try to access the XML response it shows 0 results. I have created a pre-search rule, if query parameter has "Site=aemquickstart", then use a different template. Is there any change I need to do at template level to see results in XML response? http://spXXXXX.guided.ss-omtrdc.net/?Site=aemquickstart

Views

520

Likes

0

Replies

5
Default image URL in Adobe Search and Promote
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Hi, After indexing product metadata in Adobe Search and Promote, I noticed few image URLs are broken in Reports-> Data view. Is there are way in S&P to update the broken image URLs to default image URL after indexing is done?

Views

428

Likes

0

Replies

3
Search and Promote autocomplete feature with collections
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Hi,I am trying to fetch auto complete results from search and promote using below URL. But this is searching entire S&P account. Do we have any query parameter like sp_k to get auto complete results from specific collection? https://content.atomz.com/autocomplete/sp**/**/**/**?query=test%2C&beginning=1&max_results=10

Views

2.3K

Likes

0

Replies

1
Re: Search and Promote autocomplete
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
This is a custom component.

Views

4.1K

Likes

0

Replies

0
Search and Promote autocomplete
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Hi, How can we have multiple searchbars with autocomplete enabled on a page. For example, I have searchbar in header and footer section, autocomplete feature is working with id="q" parameter. We can't have duplicate id on the HTML. Any pointers on how to enable autocomplete feature for both searchbars on header and footer.

Views

4.2K

Likes

0

Replies

4
Re: Adobe Search & Promote - Did you mean feature
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
I already have it in transport template too but no luck. I have tried the snippet which you shared even, but it didn't work. guided.tmpl json.tmpl "suggestions": [ { "suggestion":"", "count": "" }, ],

Views

6.3K

Likes

0

Replies

0
Adobe Search & Promote - Did you mean feature
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
I am trying to implement "Guided Suggestions" feature in Search & Promote. I have added below code in presentation template. But I don't see any suggestions in S&P response. Any pointers would be helpful. Code added in Presentation Template: 10<guided-suggestion-original-query/>10<guided-suggestion-path /><guided-suggestion /> S&P response:00

Views

6.8K

Likes

0

Replies

3
Sling Dynamic Include with Cloudfront
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Sling Dynamic Include works with AEM Dispatcher, is there a way to use the same feature with Cloudfront, so component caching can be avoided.

Views

2.8K

Likes

0

Replies

3
Connect to repo.adobe.com:443 [repo.adobe.com/192.147.130.162] failed: Connection refused: connect
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
I am facing connection issue to Adobe repo during maven build. I can access Adobe Public Maven Repository from browser.https://repo.adobe.com/nexus/content/groups/public/ Any idea why this is happening?

Views

1.8K

Likes

0

Replies

2
Re: Fetch results using Collections in Search and Promote
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
It's working after I rename the index connector name (added underscore), it's not working if index connector name is a single word like site1index.

Views

1.7K

Likes

0

Replies

0
Fetch results using Collections in Search and Promote
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Hi,I am trying to fetch search results using Collections feature in Search and Promote.I have two index files site1_index, site2_index where site1_index has two products which are also present in site2_index. I am able to fetch results for site2 collection but not for site1 collection. If I remove site2_index from URL entry point then able to see results for site1 collection. URL Entrypointsindex:site1_indexindex:site2_indexCollectionssite1 regexp index:site1_index*site2 regexp index:site2_index...

Views

1.8K

Likes

0

Replies

1
Re: Creating Scheduler with Config Factory using OSGI R6 annotations
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Thanks Jbrar, link shared by you works for single scheduler instance, I am looking for creating multiple instances like belowScheduler Factory +Scheduler 1 for Site 1Scheduler 2 for Site 2

Views

2.0K

Likes

0

Replies

0
Creating Scheduler with Config Factory using OSGI R6 annotations
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
I need to create a scheduler for multiple sites, so thought to use Config Factory so I can add a scheduler instance for each site. Do we have a helpx article to create a scheduler with Config Factory using OSGI R6 Annotations.

Views

2.6K

Likes

0

Replies

3
Re: Can we pass Angular state in AEM SPA framework
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Thanks, I have gone through those links, these links hold good for marketing sites.Is SPA framework SEO friendly? I see tag has only element, and HTML schema is rendered from Angular components.We are declaring cq:pagemodel_root_url in index.html, this holds good for single site. How can we handle situation when we have multiple sites like /content/site1, /content/site2? How do we configure the cq:pagemodel_root_url in same git project?SPA framework fetches the jcr:content in angular.model.jso...

Views

4.4K

Likes

0

Replies

0
Can we pass Angular state in AEM SPA framework
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
I see Adobe has introduced SPA framework in 6.$ SP2. Would like to know if this framework holds good for eCommerce sites?. Can we pass angular state when we traverse from one page to another?. If yes, is there a working prototype or demo?

Views

4.5K

Likes

0

Replies

2
Re: Adobe Search & Promote Collections
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
I tried to Test Collections in S&P, but am getting error "Collection: Not in a collection"

Views

4.8K

Likes

0

Replies

0
Adobe Search & Promote Collections
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
I have product catalog indexed in S&P, can we group the products using collections?Collections in S&Pcollection1 => https:///search.html?q=*&x1=format1collection2 => https:///search.html?q=*&x1=format2If I use sp_k=collection1, then can I get results only from product format1?

Views

4.8K

Like

1

Replies

2
Re: search and promote in french is not fetching results for the entire combination
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Try creating a Post Search Rule in SnP as below.If all of the following conditions are met: Template's search results in template for search default equal value 0Perform the following actions: Perform regex on template's search parameter q in template for search default pattern (.*) substitution *$1*

Views

1.8K

Likes

0

Replies

0
Re: Create a PDF out of an AEM page
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Do we have any updates for this feature in AEM 6.4?

Views

2.5K

Likes

0

Replies

0
Does SCR annotations work in AEM 6.4?
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Hi,I am upgrading AEM 6.2 to AEM 6.4 (archetype 13), I am using SCR annotations in AEM6.2. I tried to use same SCR annotation for time being rather than using OSGI declarative services annotations in AEM6.4. When I use SCR annotations, "Declarative Service Components" are in satisfied state, when I use OSGI annotations, I can see component is active.Is SCR annotations compatible in AEM 6.4?

Views

1.9K

Likes

0

Replies

2
Re: osgi values not being saved in AEM 6.2
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Any luck? I am facing the same issue.

Views

9.6K

Likes

0

Replies

0
Re: Maven Build failure - RepositoryException: Inaccessible value (500)
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Package is installed to author instance but not to publish.

Views

2.3K

Likes

0

Replies

0
Maven Build failure - RepositoryException: Inaccessible value (500)
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Hi, I am facing an intermittent issue, sometimes maven build is getting failed and not able to install the packages. I can access package manager console and logged with admin creds. There is enough disk space on server. Any pointers?AEM Version: AEM 6.2Maven Version: Apache Maven 3.0.4Error logs:[ERROR] Request failed: org.apache.jackrabbit.vault.packaging.PackageException: javax.jcr.RepositoryException: Inaccessible value (500)[INFO]-------------------------------------------------------------...

Views

4.0K

Likes

0

Replies

4
Nullpointer when injecting ResourceResolverFactory in AEM 6.2
Avatar
Ignite 40
Level 4
kishore_polsani
Level 4

Likes

11 likes

Total Posts

77 posts

Correct reply

7 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 25
Ignite 20
Ignite 10
View profile
kishore_polsani
- Adobe Experience Manager
Hi All,I am getting null pointer when using @Reference annotation to get ResourceResolverFactory object in an OSGI service. Any pointers???Code used:@Service@Component(immediate = true)public class MyService{ @Reference private ResourceResolverFactory resolverFactory;}Pom.xml:maven-scr-plugin version is 1.20.0org.apache.felix.scr.annotations version is 1.9.8Thanks,Kishore

Views

1.5K

Likes

0

Replies

1