Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

shivama92274331
Community profile shivama92274331 Level 2
Job title here
Location here
4 BADGES
Level 2

Level 2

Learn more
Joined the community 22-10-2019 5:18:43 AM
Offline
Top badges earned by shivama92274331
Customize the badges you want to showcase on your profile
Re: Post Migration of Tags not showing in PageProperties
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hello Friends, The issue is resolved now! Problem was after successful migration of tags the corresponding value of tag saved in page nodes was not displaying on page properties because the corresponding tag and its path was not available in cq:tags, once we rectified with the tags package its started showing up tag value on page properties. Thanks for all of your suggestions. Regards,Shivam

Views

86

Like

1

Replies

1
Re: Post Migration of Tags not showing in PageProperties
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi @asutosh_jena , I have restarted the instance twice as per the docs and on forum solutions. The tag property is coming into the page nodes but they are not dispaying on the page properties under tag selection.

Views

114

Likes

0

Replies

0
Re: Post Migration of Tags not showing in PageProperties
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi @asutosh_jena,

Views

115

Likes

0

Replies

0
Post Migration of Tags not showing in PageProperties
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hello Friends, I am performing AEM 6.4 to 6.5 migration, the tags have been copied to new location /content/cq:tags and old location /etc/tags have been deleted and content pages are re-installed. Post migration i can see the tag property ["currentPageTag"] is coming into the page nodes which is absolutely fine and my old tags are retained in nodes.Issue: the tag values stored in the nodes as property["currentPageTag"] are not coming/displaying in page properties under current Page Tag section, ...

Views

197

Likes

0

Replies

6
Re: Rewrite url not working for html extension in source...
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi lucian_nicolaescu, i agree with you order of rewrite rules matter, but in this case the rewrite urls were working with same order. Recently in past we have done migration of our dispatcher setup to newer one 4.1.9 after this it seems to have issue.

Views

151

Likes

0

Replies

0
Re: Rewrite url not working for html extension in source...
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi @BrianKasingli, the 3 urls shared here are one of the rewrite url set which is not working, all the rewrite urls having .html as extension is not working.

Views

150

Likes

0

Replies

0
Rewrite url not working for html extension in source url.
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi,The rewrite rules are not working for having source url's extension as html, they are not redirecting to the destination url on browser and source url remains same, for example below redirects don't work while other redirects having no extension or other extension are working fine. Any leads? 1. RewriteRule ^/applications/life-science-research.html /en/products-solutions/all-application.html [R=301,L,NC]2. RewriteRule ^/applications/life-science-research/dna-sequencing.html /en/products-solut...

Views

273

Likes

0

Replies

5
Re: logged in user information gets interchange with anot...
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi @KiranVedantam1992 , I have tried your solution but unfortunately it didn't work.

Views

194

Like

1

Replies

1
logged in user information gets interchange with another user
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
I have the below use case: I am using AEM 6.4 version. There is a third party integration with Magento. The session object gets interchange(i think so) as the logged in user information (first name, last name) gets interchange with another user,for example User A is logged in but intermittently on page header it shows user name as B or any other random user name, sometimes it shows correct user name as well. The sling model is using in the code to retrieve the session id and then fetching the us...

Views

250

Likes

0

Replies

4
Re: Not able to see x-dispatcher param in response headers
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi @Vijayalakshmi_S Thanks for your reply, it worked after adding Header always add X-Dispatcher ${DISP_ID} in vhost file.

Views

138

Likes

0

Replies

0
Not able to see x-dispatcher param in response headers
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi, i am not able to see the value of x-dispatcher (used to see which dispatcher is serving request)parameter info in the response headers when i see chrome console, does any config exist to enable/disable it in dispatcher files?? Thanks,Shivam

Views

251

Likes

0

Replies

3
'renderid' cookie is not generating
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi,The renderid cookie is not creating which should be generating after enabling the /sticky connections in dispatcher file, below is the configuration. The same config is working on stage but not on prod. /stickyConnectionsFor "/content/myproject/en-us" PS: i haven't enabled any /sessionmanagement Thanks,Shivam

Views

198

Likes

0

Replies

1
Re: jcr session is returning 'anonymous' user or some els...
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi, KiranVedantam1992,with your solution you have adapted resources class also in @adaptables{ Resource.class,SlingHttpServletRequest.class}For below request object is it creating from resources class or httpservletrequest class? slingRequest.getResourceResolver().adaptTo(Session.class); Thanks,Shivam

Views

218

Like

1

Replies

1
Re: jcr session is returning 'anonymous' user or some els...
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi @Anudeep_Garnepudi,I tried it earlier to get the ressourceresolver object from request but it didn't work, this time i made one change i used @self annotation for request object earlier i was using @inject for request object, good part is its worked on stage environment and bad part is it didn't work on Prod environment. No 2 question arises. 1) will it really make any difference if we use @self annotation instead @inejct2) how the same configuration is not woring on Prod while it worked on s...

Views

240

Likes

0

Replies

0
Re: on adding samesite cookie in headers the content page...
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
I have fixed it now, the HttpOnly attribute in header was redirecting it to the login page.

Views

153

Like

1

Replies

0
jcr session is returning 'anonymous' user or some else session's data
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi,I am geting the jcr session clash/exchanged with other sessions, the logged in user details are replaced with other user's details intermittently or userid is coming as 'anonymous'. Any help for this issue? below is the code i am using in sling model class.@Model(adaptables = { SlingHttpServletRequest.class })public class UserLoggedInModel@SlingObjectResourceResolver resourceResolver;@PostConstructprotected void initialize(){String firstNamePath = "./profile/firstName";String lastNamePath = "...

Views

358

Likes

0

Replies

6
on adding samesite cookie in headers the content page is autoredirecting to login page
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi All,On adding below configuration “samesite cookie” in vhost file under headers section , we are getting the issue the page is auto redirecting to the login page which is hosted on Magento after around 20 seconds. Header edit Set-Cookie ^(.*)$ $1;HttpOnly;Secure;SameSite=None Apache version: 2.4 Any leads for this. Thanks

Views

219

Likes

0

Replies

2
Re: SAML Authentication generates anonymous user session instead of authenticated user
Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
- Adobe Experience Manager
Hi, did you find the solution for this issue? i am also having similar issue.

Views

8.5K

Likes

0

Replies

0
Likes given to
Likes from