since ‎06-11-2019
‎18-08-2020
bryane54211190
Level 1
Re: Custom DAM Publish Actions bryane54211190 - Adobe Experience Manager
Hello, thanks for your reply and sorry for the delay in the response. I tried to recreate your code, but when I go into the DAM on my localhost there is no new button added under Quick Publish after selecting an image asset. The steps I took to attempt this were to use CRXDE Lite and go to the path:/libs/wcm/core/content/editor/jcr:content/content/items/content and click on Overlay Node and hit OK with the default settings provided. After I attempted to add the nodes as specified by the XML you ...
63
Views
0
Likes
0
Comments
Custom DAM Publish Actions bryane54211190 - Adobe Experience Manager
I was wondering if someone could point me in the direction to some articles, API documentation, or the proper terms to google in order to create a custom action under the Quick Publish selection and Manage Publication options under the navigation menu for the DAM. The exact use case for this would be that we would like to use the DAM as a central repository for our digital assets and right now when we click on an image or pdf in the DAM we can select under Quick Publish options for "Publish to A...
112
Views
0
Likes
2
Answers and Comments
404 errors from root of site start with a 301 redirect bryane54211190 - Adobe Experience Manager
Hello, our site works fine with custom 404 pages served from our language directories where the error page is displayed properly and the status returned is a 404 on the initial page hit at the specific URL in question. If, however, we hit the root of the site with an invalid link the custom error page is displayed, however viewing the network tab in a browser it first does a 301 redirect before hitting the custom error at /en-us/error/404 (so the URL does end up changing). Looking into this, I f...
2264
Views
0
Likes
2
Answers and Comments
Re: Query Builder does not work on 1 publisher instance bryane54211190 - Adobe Experience Manager
Just a follow up to this. I worked with the Adobe Managed Services team on this and after a few unsuccessful rounds attempting to rebuild the indexes using the tool mentioned at:https://docs.adobe.com/content/help/en/experience-manager-learn/foundation/administration/use-oak-run-jar-to-manage-indexes.html#index-consistency-check the issue was eventually resolved by the AMS team by copying the working index from publisher 2 to the publisher 1 instance.
1387
Views
0
Likes
0
Answers
Re: Query Builder does not work on 1 publisher instance bryane54211190 - Adobe Experience Manager
What I did to compare the indexes was to compare publisher 1's /oak:index.tidy.1.json and publisher 2's oak:index.tidy.1.json to compare the structure of the indexes and they were the same except for the number of reindexes (I tried a reindex on the publisher 1 instance). So far everything seems the same.
1822
Views
0
Likes
0
Comments
Re: Query Builder does not work on 1 publisher instance bryane54211190 - Adobe Experience Manager
Just to follow up on this. I ran the query performance tool on our publisher 2 instance where the query works and it is actually using a different index, ntBaseLucene and properly gives logs. It is only on the Publisher 1 instance that I get the error. I've tried reindexing the ntBaseLucene index but I still get the error when attempting to explain the query.
1845
Views
0
Likes
0
Comments
Re: Query Builder does not work on 1 publisher instance bryane54211190 - Adobe Experience Manager
Thanks for your reply.When I try and view the rss page which performs the query I get a server 500 error and this appears in the error.log 02.03.2020 00:00:37.159 *ERROR* GET /en-us/blog.rss.xml HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingExceptionorg.apache.sling.scripting.sightly.SightlyException: org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: org.mozilla.javascript.WrappedException: Wrapped java.lang.NullPointerException (/libs/...
1491
Views
0
Likes
0
Comments
Re: Query Builder does not work on 1 publisher instance bryane54211190 - Adobe Experience Manager
Yes, I've tried to reindex cqPageLucene (by toggling the reindex value to true in crxde lite). When I try and view the queryPerformance tool and do an Explain Query on my query i get an error popup:An error occurred while explaining the query. nullcom.day.cq.search.impl.builder.QueryBuilderImpl.getComponent(QueryBuilderImpl.java:278)com.day.cq.search.impl.builder.QueryImpl.getPredicateEvaluator(QueryImpl.java:250)com.day.cq.search.impl.builder.EvaluationContextImpl.getPredicateEvaluator(Evaluati...
1853
Views
0
Likes
0
Comments
Query Builder does not work on 1 publisher instance bryane54211190 - Adobe Experience Manager
We have a component that runs a query builder to generate an RSS feed of blog posts. This component seems to work fine on all environments (We are hosted on AMS with a dev environment, stage and production) on both author and publish instances except for our production publisher 1 instance (we have 2 publish servers in production). This does not seem to be an issue with our component itself as I've tried debugging the query in the Query Builder Debugger and the query works fine everywhere but st...
4464
Views
0
Likes
8
Answers and Comments