Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Manh_Nguyen
Manh_Nguyen
Offline

Badges

Badges
14

Accepted Solutions

Accepted Solutions
1

Likes

Likes
5

Posts

Posts
29

Discussions

Discussions
3

Questions

Questions
26

Ideas

Ideas
0

Blog Posts

Blog Posts
0
Top badges earned by Manh_Nguyen
Customize the badges you want to showcase on your profile
Missing resource on AEM inbox
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,When I tried to publish a page using a custom workflow, I received this message when opening AEM inbox. It's saying that "the resource used to start this instance does not exist anymore". May I know what is this message? Any help would be appreciated.The version is 6.2 SP1 with CFP14.Thanks.

Views

1.1K

Likes

0

Replies

1
Re: AEM not loaded after compaction
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,Thanks for your advise! Looks like it's because the user that run AEM does not have the permission RW to the *.tar file. I changed the owner and AEM can be started.Thanks a lot.

Views

975

Likes

0

Replies

0
Re: AEM not loaded after compaction
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,Thanks for your reply.Yes I'm able to access /system/console. And all bundles are active. But I had to login using default admin account although I had changed admin password.

Views

906

Likes

0

Replies

0
AEM not loaded after compaction
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,I have an issue after running compaction for my system, the compaction log said compaction was successful. But when starting up, all of the requests are returning 503 including crx/de. I tried accessing OSGi bundles and all are started and active. Also checked error.log but nothing found. I also had to key in the default admin password to access to OSGi bundles although I've changed the admin password (password was working before compaction).I noticed in stdout.log, it's missing the loading o...

Views

1.4K

Like

1

Replies

3
Re: AEM Vanity URL take too long to update
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,I did notice that, the old rules in jcrresolver is still there even I removed vanity URLs for my page. Tried restarting the AEM instance but these rules are still there. Does something stuck so these rules cannot be removed?

Views

973

Likes

0

Replies

0
Re: AEM Vanity URL take too long to update
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Thanks all for the reply.I'm testing this in author, so the change should be reflected immediately after I added or updated vanity url.gauravb10066713​ The vanity URL does not appear on Sling Resource Resolver and it's not working when I'm trying this in web browser.

Views

978

Likes

0

Replies

0
AEM Vanity URL take too long to update
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,When we add a new or update a vanity URLs to the page and save the config. The changes are not reflected immediately. But after few hours later, we do a check again, then the vanity URL can be used.I also did a check right after creating a new vanity URL for my page, on Sling Resource Resolver (/system/console/jcrresolver), but nothing was updated as I can observe. But after few hours, the new vanity URL has been appeared on Sling Resource Resolver mapping, and I can use this Vanity URL.From ...

Views

2.6K

Likes

0

Replies

7
Re: [Dispatcher] .stat file not generated
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi guys,Thanks for sharing your thought.I found the issue, that the dispatcher flush agent is set the HTTP headers to "CQ-Action-Scope: ResourceOnly". I removed it then do a replicate, the .stat files are generated. From my understand, it's used for the dispatcher flush rules inside ResourceOnly. Can I know if I remove this from dispatcher flush agent is ok? I still have some dispatcher flush rules inside ResourceOnly (in OSGi config).Regards,Manh

Views

2.1K

Likes

0

Replies

0
Re: [Dispatcher] .stat file not generated
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi guys,Thanks for replying.I checked at the path /mnt/cache/content/mywebsite with command "ls -la", but I see no stat file created (I'm logged as root).

Views

2.1K

Likes

0

Replies

0
[Dispatcher] .stat file not generated
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,I'm configuring dispatcher to generate the .stat file from the config:/cache{ # the cacheroot must be equal to the document root of the webserver /docroot "/mnt/cache" # sets the level upto which files named ".stat" will be created in the # document root of the webserver. when an activation request for some # handle is received, only files within the same subtree are affected # by the invalidation. /statfileslevel "1"}By right, the stat file should be auto-generated at docroot (/mnt/cache) wh...

Views

5.6K

Likes

0

Replies

10
Re: OSGi bundle not working until restarted
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi Arun,Thanks for your reply.Like you said, I found that there is no immediate=true inside @Component, however, the function inside the component was working correctly when first install the package, but I leave this bundle for a few days and do a re-test, this function is not working anymore.

Views

867

Likes

0

Replies

1
OSGi bundle not working until restarted
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,I have a problem of the OSGi bundle not working. When first upload and install the package which contain the bundle, all the functions from the bundle was working and status is "active". And then I didn't touch the bundle for few days, then some functions of this bundle are not working until I stop then start the bundle again.Please let me know how to resolve this permanently, because restarting the bundle is not an option for this. Any help would be appreciated.Thanks and Regards,Manh

Views

1.2K

Likes

0

Replies

3
RolloutManager: rollout still remove local edit
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,I'm currently implementing rollout function for populating data to pages, but when I tried to edit the page (add components...) then rollout, even I set the "reset" value to true or false, the local edit still being removed after rollout. I refer to this function: RolloutManager ("The Adobe AEM Quickstart and Web Application.") Please advise me on this. Any help would be appreciated.Regards,Manh

Views

363

Likes

0

Replies

0
Re: Dam image mark as "outdated"
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,I got the answer. It's because the last modified time is after the last published time.

Views

692

Like

1

Replies

0
Dam image mark as "outdated"
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,When I'm publishing a product with a DAM reference, it said that the DAM image is outdated. Can I know what that mean? Also this image is published months ago.When check the API, it has the status for reference DAM image.{"assets": [{"type": "asset","path": "/content/dam/myimage.jpg","name": "myimage.jpg","published": true,"outdated": true,"status": "outdated","disabled": false,"lastPublished": 1516086825781,"lastModified": 1533277309333}]}Any help would be appreciated.Regards,Manh

Views

831

Likes

0

Replies

2
Re: Audit Log for useradmin activity
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Thanks Arun.However, I already know how to add a custom log, I just want to know which logger should I insert to get the activity log of useradmin.I refereed to this article: How to Audit User Management Operations in AEM Regards,

Views

654

Likes

0

Replies

0
Audit Log for useradmin activity
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,I'm trying to create audit log for useradmin activity (create user/group, add user to group, remove user from group...). I've read an article about adding this config in Apache Sling Logging Logger:Log Level: InformationLog File: logs/useraudit.logMessage Pattern: leavel defaultLogger: com.adobe.granite.security.user.internal.audit, com.adobe.granite.security.user.internal.servlets.AuthorizableServletbut it didn't work, try create/delete user but there is no log written. Is there anyway to ad...

Views

1.2K

Likes

0

Replies

4
Re: Make query string to be cached in dispatcher
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Thanks Feike.Currently I'm doing the query string for filter, and it call the REST API service for getting the data. Is your way applied for REST API services? And Is there any document/guide on how to apply the queries for REST services?Thanks in advanced,Manh

Views

2.4K

Likes

0

Replies

0
Re: Make query string to be cached in dispatcher
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Thanks for your reply.From your webinars, I learned that dispatcher only cached the urls with extension (.html). So I triedmywebsite.com/homepage.html/x/3 ---> will not be cachedmywebsite.com/homepage.html/x/3.html ---> will be cached [1]But I have a problem, if [1] is cached, when I try to access mywebsite.com/homepage.html, it returns 404. Is it because of homepage.html is a directory, not file anymore? and is there anyway to resolved it? Appreciated for your help.Thanks.

Views

2.4K

Likes

0

Replies

0
Re: Make query string to be cached in dispatcher
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi kautuksahni,Thanks for your reply.From what you suggest, you mean that I need to rewrite the url to be something like:"mywebsite.com/homepage.html?y=2" to "mywebsite.com/homepage/y/2"Is that correct? If so, is there any guide/document on how to do it? I'm new on configure dispatcher, so any help would be appreciated.Thanks,Manh

Views

2.4K

Likes

0

Replies

0
Make query string to be cached in dispatcher
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,I'm trying to make the query string to be cached in dispatcher in separated files. Have read an article about Configuring Dispatcher, I tried /ignoreUrlParams { /0003 { /glob "*" /type "allow" } }but it keeps caching one files instead of multiple files as I'm trying to used many queries. For example:I tried: mywebsite.com/homepage.html?x=1 and mywebsite.com/homepage.html?y=2, but the cache only have homepage.htmlIs there any way to make multiple caches by different queries?Any help would be a...

Views

4.3K

Like

1

Replies

8
Re: Publisher write too many Lucene logs
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Thanks for your reply. Can you show me how to reindex? Any document or guide is appreciated.

Views

659

Likes

0

Replies

0
Publisher write too many Lucene logs
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,We receive 1 of our publisher (we have 2 publishers) is writing to many "Lucene" logs inside error.log file, the amount of this error.log is too big now (hundreds of gb), other publisher is working fine, not writing any "Lucene" logs. We cannot do replication to this publisher because there is no space since the error.log is too big.Tried restarting this publisher but it stills writing logs. I've include one of the case that it wrote out (it's too heavy so I cannot copy some). I've deactivate...

Views

1.4K

Likes

0

Replies

4
Adding hreflang tag to website
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi team,I want to add the hreflang tag to my website for better SEO. From my research, the hreflang tag can be inserted inside , and I saw from example that they use the href straight from their website, but is it possible to do it for the content page in AEM?My idea is using this:Please kindly help and advise.Thank you very much,Manh

Views

2.4K

Like

1

Replies

1
Re: Revert older version of CFP
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Thanks all for your reply,I found a package that this version is not compatible with my custom scaffolding. It's possible to restore this package to previous version, without uninstalling the whole CFP-14 right?com.adobe.granite.ui.content-0.8.362-CQ620-B0036.zipThanks,Manh

Views

1.2K

Likes

0

Replies

0
Re: Revert older version of CFP
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,I got this error when trying to uninstall via package manager:Error: javax.jcr.nodetype.ConstraintViolationException: OakConstraint0021: /home/users/A/As3xGtSMmEA1LxHNIA6R/.tokens/2018-05-22T15.29.45.872+08.00[[rep:Token]]: Mandatory property rep:token.key not found in a new nodeI have no idea what this is... anyway to fix this?

Views

1.0K

Likes

0

Replies

0
Re: Revert older version of CFP
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Thanks for your reply.Am I supposed to uninstall CFP? I read the release note and see that uninstalling CFP is not supported. I'm using AEM 6.2 SP1.Adobe Experience Manager Help | Release Notes: AEM 6.2 Cumulative Fix Pack

Views

1.1K

Likes

0

Replies

0
Revert older version of CFP
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi team,I created a custom scaffolding for my project, it works fine until I installed CFP-14. One of the field is not showing value, when click save, it will store empty value to our database. I found that my custom scaffolding still working with previous version, can I know is there anyway to restore back?Thanks.Regards,Manh

Views

2.6K

Like

1

Replies

7
Help: SMTP keeps getting error
Avatar
Boost 5
Level 3
Manh_Nguyen
Level 3

Likes

5 likes

Total Posts

29 posts

Correct reply

1 solution
Top badges earned
Boost 5
Ignite 10
Give Back 10
Give Back 5
Ignite 5
View profile
Manh_Nguyen
- Adobe Experience Manager
Hi,We keeps getting error from sending email through SMTP. We are using Day CQ mail service to send email through our SMTP server. Since our SMTP server doesn't require username/password for sending email, so I put empty value for user/password this this configuration.The 2 classes below are just for putting email template, sender, subject... to the HtmlEmail and send it by using com.day.cq.mailer.MessageGateway.Here's the error log:com.day.cq.mailer.MailingException: org.apache.commons.mail.Ema...

Views

501

Likes

0

Replies

0