Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

krishc76025392
Community profile krishc76025392 Level 2
Job title here
Location here
4 BADGES
Level 2

Level 2

Learn more
Joined the community 23-06-2017 3:55:50 AM
Offline
Top badges earned by krishc76025392
Customize the badges you want to showcase on your profile
Multifield cta is not working from sling model
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Hi All,i have a custom multi field which stores values in below structure.and i am trying to get the values as below in my htl file. i am iterating a list of carousel- item0 , item1 and the inside cta-item0, item1.The issue is my htl component should show cta-item0 for carousel item 0 and accordingly for second carousel too ,but shows second cta - item0 and item1 only from second carousel item. ${item.carouselText @ context='html'} my sling model logic is public List getCtaList() { return ct...

Views

335

Likes

0

Replies

1
Re: Dynamic injection of values into sling model is not working
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
in HTL i used list navigation as below

Views

2.9K

Likes

0

Replies

1
Dynamic injection of values into sling model is not working
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Hi All,i am trying to inject some values dynamically into sling model and retrieve some properties of that injected value and print them as below which is not working and throwing a null pointer exception which is not appropriate.i can see sling model is registered in adapters.some one please tell me where it went wrong.Any help is highly appreciated.In below i want to send each item of list dynamically to sling model via "selectPath" and process the valur for a property in sling model and retri...

Views

3.5K

Likes

0

Replies

6
AEM Workflows in 6.3 causing asset to be unprocessed.
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Hi All,My requirement is to exclude a dam folder path in workflow launcher for dam update asset workflow.i did it by following below link:How to exclude certain AEM Assets folders from generating renditions But after doing as said in above link, i can see my dam asset in "Unprocessed" state and cant be useful anymore in pages.my model of workflow is as follows.Any ideas what would be the problem and how to get rid of it.Thanks,krish.

Views

435

Likes

0

Replies

0
Resource resolver issue in aem 6.2 publishers only
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Hi ,we recently upgraded from 5.6.1 to AEM 6.2.we have a following logic in one of OSGI services.we are getting the below exception only in publisher while the same logic is working fine in author.we have given currently the root permissions for the user- xml service and used it in user mapper service along with amendment configurations.please help in resolving the below issue.LOGIC:Map param = new HashMap();param.put(ResourceResolverFactory.SUBSERVICE, "XmlService");try { //return factory.getAd...

Views

1.0K

Likes

0

Replies

2
Re: Resource resolver is already closed exception when under load
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
HI smacdonald2008, can you please provide that community article link here.

Views

1.6K

Likes

0

Replies

0
Re: wcm move command error
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Thank you smacdonald2008​. we will soon raise a support ticket.

Views

1.1K

Likes

0

Replies

0
wcm move command error
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Hi All,we recently upgraded environment from 5.6.1 to 6.2.In AEM 6.2 under site admin, if we try to use "move" option for a page below error is being shown in error logs.Please help us in resolving this.Note: we removed all the old versions from 5.6.1.30.10.2017 12:08:34.046 *ERROR* [172.16.251.189 [1509365314029] POST /bin/wcmcommand HTTP/1.1] com.day.cq.wcm.core.impl.commands.MoveCommand Error during operation.java.lang.IllegalStateException: Base version does not exist. at org.apache.jackrabb...

Views

1.5K

Likes

0

Replies

3
Re: Fluctuating Performance after upgrade from AEM 6.1 to 6.2
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
we too have the same issue. how that could be resolved?

Views

5.6K

Likes

0

Replies

1
Re: File "/META-INF/tags/openGraph.tag" not found in aem 6.2
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Hi Feike Visser,Did you raise a support ticket for the sling patch fix mentioned by chanchalesj60771443or please let me know how to use that patch in our aem environments.Thanks in advance.

Views

1.3K

Likes

0

Replies

1
Bundle is not in active state.
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Hi,we are upgrading the system from cq 5.6.1 to Aem 6.2,where we have a following setup.1.module-1 (zaxcorp-direct) is having following dependency in its pomcom.google.guavaguava2. module-2 (Zaxcorp-web) is having following dependency in its pom. com.zax zaxcorp-direct 1.0-SNAPSHOT provided com.google.guavaguava3. when two bundles are installed into AEM only one among them is active and error is thrown as below. Zaxcorp-web bundle is in Installed state.(Module-2) Zaxcorp-direct bundles is in act...

Views

833

Likes

0

Replies

0
File "/META-INF/tags/openGraph.tag" not found in aem 6.2
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Hi,we are upgrading the system from cq 5.6.1 to aem 6.2,where we have a following setup.1. A ".tld" file is written with both and attributes.2. and tag files are defined in the tld file as below Generate social metadata from page properties getOpenGraphFieldsFromPage com.new.hype.f12.ui.tags.OpenGraphTag empty openGraph /META-INF/tags/openGraph.tagThe above setup is working fine in cq 5.6.1 but not here in 6.2.Now when we are accessing a page, we can see the below error in error.logorg.apach...

Views

1.7K

Likes

2

Replies

8
Re: Missing entry in config manager in aem 6.2
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Hi Jitendra,i checked it, it got registered as service and visible in console/services.

Views

1.3K

Likes

0

Replies

0
Re: Missing entry in config manager in aem 6.2
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Hi zeeshank15007365Bundle is in active state and service is registered and visible under system/console/services.

Views

1.3K

Likes

0

Replies

0
Missing entry in config manager in aem 6.2
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Hi,we updated cq 5.6.1 to aem 6.2 recently and came across below issue.There is a configuration service that need to visible in "system/console/configMgr" but not listed in aem 6.2.That service looks like below:@Component(metatype = true, immediate = true)@Service(DealService.class)@Properties({ @Property(name = "service.pid", value = "com.me.now.dealer.service.DealService"),})public class DealService extends GenericQueryService implements DealerService {}And i can see below log in error.log and...

Views

1.8K

Likes

0

Replies

5
Re: Felix scr annotations are not working in aem 6.2
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Hi Techaspect,we followed the dependencies suggested by you and now services are coming up.Thank you for your suggestion..Regards,Krishchopps.

Views

1.1K

Likes

0

Replies

0
Felix scr annotations are not working in aem 6.2
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
Hi,we migrated from cq 5.6.1 to AEM 6.2 and observed that few services are not working in AEM 6.2.@component and @service annotations are not making our class registered as component and service in felix-->OSGI--->Services.The dependencies in our POM is as below:org.apache.felixorg.apache.felix.scr.annotations1.9.0providedDoes anybody know why it happened and how to fix it?

Views

4.2K

Likes

2

Replies

5
Issue with Spring integration in Aem upgrade
Avatar
Validate 1
Level 2
krishc76025392
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
krishc76025392
- Adobe Experience Manager
we have a setup all that is needed to make Spring beans referenceable inside of OSGi bundle code and accessible as an OSGi service.But when the bundle with spring beans are installed in felix, the bundle is in "Active" state but osgi-->services will not show the desired services injected through spring.when bundle is stopped and restarted, below log can be seen.*INFO* [EclipseGeminiBlueprintExtenderThread-15] org.eclipse.gemini.blueprint.extender.internal.dependencies.startup.DependencyServiceMa...

Views

459

Likes

0

Replies

0