since ‎23-06-2017
‎10-12-2019
krishc76025392
Level 2
Multifield cta is not working from sling model krishc76025392 - Adobe Experience Manager
Hi All,i have a custom multi field which stores values in below structure.and i am trying to get the values as below in my htl file. i am iterating a list of carousel- item0 , item1 and the inside cta-item0, item1.The issue is my htl component should show cta-item0 for carousel item 0 and accordingly for second carousel too ,but shows second cta - item0 and item1 only from second carousel item. ${item.carouselText @ context='html'} my sling model logic is public List getCtaList() { return ct...
268
Views
0
Likes
1
Answers and Comments
Re: Dynamic injection of values into sling model is not working krishc76025392 - Adobe Experience Manager
in HTL i used list navigation as below
2529
Views
0
Likes
1
Replies
Dynamic injection of values into sling model is not working krishc76025392 - Adobe Experience Manager
Hi All,i am trying to inject some values dynamically into sling model and retrieve some properties of that injected value and print them as below which is not working and throwing a null pointer exception which is not appropriate.i can see sling model is registered in adapters.some one please tell me where it went wrong.Any help is highly appreciated.In below i want to send each item of list dynamically to sling model via "selectPath" and process the valur for a property in sling model and retri...
3157
Views
0
Likes
6
Replies
AEM Workflows in 6.3 causing asset to be unprocessed. krishc76025392 - Adobe Experience Manager
Hi All,My requirement is to exclude a dam folder path in workflow launcher for dam update asset workflow.i did it by following below link:How to exclude certain AEM Assets folders from generating renditions But after doing as said in above link, i can see my dam asset in "Unprocessed" state and cant be useful anymore in pages.my model of workflow is as follows.Any ideas what would be the problem and how to get rid of it.Thanks,krish.
364
Views
0
Likes
0
Answers and Comments
Resource resolver issue in aem 6.2 publishers only krishc76025392 - Adobe Experience Manager
Hi ,we recently upgraded from 5.6.1 to AEM 6.2.we have a following logic in one of OSGI services.we are getting the below exception only in publisher while the same logic is working fine in author.we have given currently the root permissions for the user- xml service and used it in user mapper service along with amendment configurations.please help in resolving the below issue.LOGIC:Map param = new HashMap();param.put(ResourceResolverFactory.SUBSERVICE, "XmlService");try { //return factory.getAd...
951
Views
0
Likes
2
Answers and Comments
Re: Resource resolver is already closed exception when under load krishc76025392 - Adobe Experience Manager
HI smacdonald2008, can you please provide that community article link here.
1054
Views
0
Likes
0
Replies
Re: wcm move command error krishc76025392 - Adobe Experience Manager
Thank you smacdonald2008​. we will soon raise a support ticket.
973
Views
0
Likes
0
Replies
wcm move command error krishc76025392 - Adobe Experience Manager
Hi All,we recently upgraded environment from 5.6.1 to 6.2.In AEM 6.2 under site admin, if we try to use "move" option for a page below error is being shown in error logs.Please help us in resolving this.Note: we removed all the old versions from 5.6.1.30.10.2017 12:08:34.046 *ERROR* [172.16.251.189 [1509365314029] POST /bin/wcmcommand HTTP/1.1] com.day.cq.wcm.core.impl.commands.MoveCommand Error during operation.java.lang.IllegalStateException: Base version does not exist. at org.apache.jackrabb...
1418
Views
0
Likes
3
Replies
Re: Fluctuating Performance after upgrade from AEM 6.1 to 6.2 krishc76025392 - Adobe Experience Manager
we too have the same issue. how that could be resolved?
5424
Views
0
Likes
1
Replies
Re: File "/META-INF/tags/openGraph.tag" not found in aem 6.2 krishc76025392 - Adobe Experience Manager
Hi Feike Visser,Did you raise a support ticket for the sling patch fix mentioned by chanchalesj60771443or please let me know how to use that patch in our aem environments.Thanks in advance.
1151
Views
0
Likes
1
Replies
Bundle is not in active state. krishc76025392 - Adobe Experience Manager
Hi,we are upgrading the system from cq 5.6.1 to Aem 6.2,where we have a following setup.1.module-1 (zaxcorp-direct) is having following dependency in its pomcom.google.guavaguava2. module-2 (Zaxcorp-web) is having following dependency in its pom. com.zax zaxcorp-direct 1.0-SNAPSHOT provided com.google.guavaguava3. when two bundles are installed into AEM only one among them is active and error is thrown as below. Zaxcorp-web bundle is in Installed state.(Module-2) Zaxcorp-direct bundles is in act...
801
Views
0
Likes
0
Replies
File "/META-INF/tags/openGraph.tag" not found in aem 6.2 krishc76025392 - Adobe Experience Manager
Hi,we are upgrading the system from cq 5.6.1 to aem 6.2,where we have a following setup.1. A ".tld" file is written with both and attributes.2. and tag files are defined in the tld file as below Generate social metadata from page properties getOpenGraphFieldsFromPage com.new.hype.f12.ui.tags.OpenGraphTag empty openGraph /META-INF/tags/openGraph.tagThe above setup is working fine in cq 5.6.1 but not here in 6.2.Now when we are accessing a page, we can see the below error in error.logorg.apach...
1529
Views
2
Likes
8
Replies
Re: Missing entry in config manager in aem 6.2 krishc76025392 - Adobe Experience Manager
Hi Jitendra,i checked it, it got registered as service and visible in console/services.
1165
Views
0
Likes
0
Replies
Re: Missing entry in config manager in aem 6.2 krishc76025392 - Adobe Experience Manager
Hi zeeshank15007365Bundle is in active state and service is registered and visible under system/console/services.
1165
Views
0
Likes
0
Replies
Missing entry in config manager in aem 6.2 krishc76025392 - Adobe Experience Manager
Hi,we updated cq 5.6.1 to aem 6.2 recently and came across below issue.There is a configuration service that need to visible in "system/console/configMgr" but not listed in aem 6.2.That service looks like below:@Component(metatype = true, immediate = true)@Service(DealService.class)@Properties({ @Property(name = "service.pid", value = "com.me.now.dealer.service.DealService"),})public class DealService extends GenericQueryService implements DealerService {}And i can see below log in error.log and...
1708
Views
0
Likes
5
Replies
Re: Felix scr annotations are not working in aem 6.2 krishc76025392 - Adobe Experience Manager
Hi Techaspect,we followed the dependencies suggested by you and now services are coming up.Thank you for your suggestion..Regards,Krishchopps.
791
Views
0
Likes
0
Answers
Felix scr annotations are not working in aem 6.2 krishc76025392 - Adobe Experience Manager
Hi,we migrated from cq 5.6.1 to AEM 6.2 and observed that few services are not working in AEM 6.2.@component and @service annotations are not making our class registered as component and service in felix-->OSGI--->Services.The dependencies in our POM is as below:org.apache.felixorg.apache.felix.scr.annotations1.9.0providedDoes anybody know why it happened and how to fix it?
3801
Views
2
Likes
5
Answers and Comments
Issue with Spring integration in Aem upgrade krishc76025392 - Adobe Experience Manager
we have a setup all that is needed to make Spring beans referenceable inside of OSGi bundle code and accessible as an OSGi service.But when the bundle with spring beans are installed in felix, the bundle is in "Active" state but osgi-->services will not show the desired services injected through spring.when bundle is stopped and restarted, below log can be seen.*INFO* [EclipseGeminiBlueprintExtenderThread-15] org.eclipse.gemini.blueprint.extender.internal.dependencies.startup.DependencyServiceMa...
430
Views
0
Likes
0
Answers and Comments