Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Form loses fragments when I run it

Anonymous
Not applicable

Hi

I've got a form which uses fragments.  This form previews fine in the designer, but when I try to run it using generatePDF Output in a process, the parts that come from the fragments are gone.

The following entries are in the log:

ALC-OUT-002-058: Cannot retrieve the resource from Repository Path.
Authority component retrieved is "..". Path component retrieved is "/Fragments/scCoords.xdp".Underlying Exception is : ALC-REP-018-000:
Resource [/Fragments/scCoords.xdp] does not exist or you do not have sufficient rights to access it.
2010-09-07 11:46:59,987 WARN
[com.adobe.livecycle.formsservice.exception.FormServerException]
ALC-OUT-002-058: Cannot retrieve the resource from Repository Path.
Authority component retrieved is "..". Path component retrieved is "/Fragments/BookmarkPage.xdp".Underlying Exception is : ALC-REP-018-000:
Resource [/Fragments/BookmarkPage.xdp] does not exist or you do not have sufficient rights to access it.
2010-09-07 11:46:59,997 WARN
[com.adobe.livecycle.formsservice.exception.FormServerException]
ALC-OUT-002-058: Cannot retrieve the resource from Repository Path.
Authority component retrieved is "..". Path component retrieved is "/Fragments/bookmarks.xdp".Underlying Exception is : ALC-REP-018-000:
Resource [/Fragments/bookmarks.xdp] does not exist or you do not have sufficient rights to access it.
2010-09-07 11:47:00,007 WARN
[com.adobe.livecycle.formsservice.exception.FormServerException]
ALC-OUT-002-058: Cannot retrieve the resource from Repository Path.
Authority component retrieved is "..". Path component retrieved is "/Fragments/scMessage.xdp".Underlying Exception is : ALC-REP-018-000:
Resource [/Fragments/scMessage.xdp] does not exist or you do not have sufficient rights to access it.

Does anyone have any idea what the problem might be?

Thanks

Dan

3 Replies
Vikas_Vijayrani
Level 3
Level 3

Please check http://kb2.adobe.com/cps/521/cpsid_52158.html

It should help you understand why the fragments are lost.

Regards

-Vikas

Anonymous
Not applicable

Thanks a lot for your reply - that certainly looks like the problem I'm running into.  Unfortunately the solutions it offers are:

  • Use only application or repository URLs for your DDX and XDP  references. All references in the DDX and XDP form and fragments must  consistently use application or repository URLs. Within the XDP form and  fragments, these references can be relative.
  • Use only absolute references within the XDP form and fragments.  (This solution applies only if application or repository URLs cannot be  consistently used.) When form designers add a fragment to an XDP form  (or to another fragment), Designer ES2 creates a reference to the  fragment. By default, the reference is a relative reference to a  fragment library. Form designers can ensure that the Assembler service  can resolve fragment references by changing the relative reference to an  absolute reference. 

I can't work out how to do either of these though.  When I add a fragment to my form I can't find a way to stop it using a relative path (ie: ..\Fragments\BookmarkPage.xdp), and if I go into the Fragment info after it's attached it shows me this path, but won't let me edit it.

Do you know how to do it?

Thanks

Dan

DanCondonJones
Level 2
Level 2

For anyone who'se interested I found the solution on this thread:

http://forums.adobe.com/thread/799719

Here it is: