Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Any patch available for Designer 8.1

Avatar

Level 2

Hi All,

We are working on a offline interactive forms for SAP CRM.

We came across a strange bug in 8.2.1 where the XDP builds up with redundant

"<?templateDesigner StyleID aped0?>" items increasing the file size enormously.

We then found a post and upgraded to 8.2.3 version but due to our SAP installation versions and constraints we need to roll back to 8.1.

So I wonder if this bug does exist in 8.1, does Adobe can provide any patch to over come this bug in 8.1.

Your help in this regard is well appriciated.

Thanks & Regards,

Sai Krishna.

1 Accepted Solution

Avatar

Correct answer by
Level 10

I have a style sheet (XSLT) that can be applied to the template to remove the repeating lines. Do you know how to apply a style sheet? If you want it post your email address and I will send it to you.

Paul

View solution in original post

10 Replies

Avatar

Level 10

Hi,

this behavior is a well known bug.

It has been fixed with an update.

How you can get the update depends on the installation of Designer (stand-alone or with Acrobat).

For more details read this article.

http://blogs.adobe.com/livecycle/2009/03/post.html

Avatar

Level 2

Hi Radzmar,

Thanks for your reply..!

Well ours is a standalone livecycle designer installation shipped by SAP.

What I noticed from the Link you provided is that, this bug exists in LiveCycle Designer ES Update 1 (8.2) and is fixed in service Pack2.

With the above information it seems this bug exist in 8.2 but I just wanted to confirm if this is noticed in 8.1 also.

i hope You got my query, please reply me if you need any info.

Thanks & Regards,

Sai Krishna.

Avatar

Level 10

The bug was introduced with 8.2.

I have not heard about this behavior in earlier versions.

Maybe the bug is there because of forms you designed in 8.2 and use now in 8.1.

You can fix this manually with a (hex) editor.

Save the forms as XDP and open this file with a (hex) editor (don't use word pad or windows editor - they may hang up).

Use the find/replace function to remove all the lines <?templateDesigner StyleID aped...> with nothing.

Save, reopen the XDP in Designer and save again to remove any fragments form the XML Source.

Then the form is fixed so far.

Avatar

Level 2

Thank you.

Yep even I didn't find any post claiming this bug on 8.1

when editing the XDP manually for the <?templateDesigner StyleID aped.."X".> do we need to remove all the occurances or the form requires atleast one entry for a set of occurances.

the below might not be relavent to this post but. can you help me.

I have a dynamic form where it enables and disables subforms on user input data.

if the form is saved with some data changes how to maintain the same status with data and dynamic content when its opened for the second time.

Right now I reprocess the entire form in form ready with script for dynamic content based on the data, i think there should be a smart way for this.

Thanks & Regards,

Sai Krishna.

Avatar

Correct answer by
Level 10

I have a style sheet (XSLT) that can be applied to the template to remove the repeating lines. Do you know how to apply a style sheet? If you want it post your email address and I will send it to you.

Paul

Avatar

Level 2

Hi Pguerett,

Thanks for the reply,

saikrishna186@gmail.com is my MailID, please forward the XSLT to this.

Also can you please explain how can I use this to remove these lines.

Thanks & Regards,

Sai Krishna.

Avatar

Level 10

Just sent you an email with the XSLT and an explanation

Paul

Avatar

Level 2

Hi pguerett ,

Sorry for the late reply..!

I used your approach with XSl you provided.

The processing doesn't take much time just a flash of second but it just publishes an empty file.

What am I doing wrong here..? do i need to edit the XSL file aswell to notify the repetative tags ...?

Thanks & Regards,

Sai .

Avatar

Level 10

Nope ....are you running it from a DOS box? This will show you any errors in the window.

If you just call the bat file from Windows then you will not see the results.

If that does not work email me the xdp file and I will run it for you.

Send it to LiveCycle8@gmail.com

Paul

Avatar

Level 2

Hi Pguerett,

After using 8.2.3 version I never came across this problem.

I am marking this post as answered.

Thanks for your help.

Cheers,

Sai