Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.
SOLVED

The acs-aem-commons subpackage isn't installing at the time of the Jenkins deployment

Avatar

Level 3

The acs-commons subpackage wasn't installed at the time of the Jenkins deployment in Dev and higher author environments but it also installed DEV publish and the local environment.

The acs-aem-commons subpackage isn't installed during the Jenkins deployment in Dev and higher author environments(We can't see the last installed timestamp). But it will install in the Dev and higher publish environment(We can see the last installed timestamp).

 

Environment

AEM 6.5.16

acs-aem-commons : 6.0.14


Please find some scenarios,
- If we install the package manually in the author environment then it will show the last installed date and time but the last installed date and time will disappear at the time of the next Jenkin deployment.
- If we increment or decrement the subpackage version then it will install the subpackage and we can see the last installed date and time but in the next deployment we can't see the last installed date and time.

 

Note: This issue is only in the author instance of Dev and higher environment(The issue does not happen locally. It happens when the build is triggered through Jenkins).

 

Hopefully, someone can give me some suggestions.

Thanks

1 Accepted Solution

Avatar

Correct answer by
Level 3

I have tried the below command and it worked as expected also every time I got the Last Installed date and time for acs-aem-commons-ui-all,acs-aem-commons-ui.content and acs-aem-commons-ui.apps.

 

 

http://localhost:4502/crx/packmgr/service/.json/etc/packages/adobe/consulting/acs-aem-commons-all-6.0.14.zip -F recursive=true

 

Ref: https://github.com/Adobe-Consulting-Services/acs-aem-commons/issues/3228

 

View solution in original post

4 Replies

Avatar

Administrator

@arunpatidar @EstebanBustamante @Mahedi_Sabuj @silk_route11 

@Shailesh_Bassi_ @Sady_Rifat @aanchal-sikka Can you please review this unanswered question? Appreciate your thoughts on this.



Kautuk Sahni

Avatar

Community Advisor

Sometimes a package might still be installing. One might need to wait for some time, to see the status.

To validate the same, verify the logs, if there is any related activity in-progress.

Also, we do not need to install the acs-aem-commons packages with each deployment. If its available in the environment with right version number, its enough.

 

You should keep it as a dependency, so thats its installed when anyone sets up their local, deploys on a new instance or upgrades ACS AEM commons, its installed/updated as per pom.xml

 

Just assure that if you deploy an updated packages, its installed without manual intervention


Aanchal Sikka

Avatar

Community Advisor

I don't fully understand your question, so are you saying that the acs-commons package is being uploaded to the AEM instance but not installed? OR are you saying that package has not even been uploaded? I don't think Jenkins has anything to do with the deployment, I could be wrong, but most of the time Jenkins will work just as your local environment, so, my recommendation would be to make sure you are embedding the "acs-commons" package in your maven project correctly and then try to create a fresh local AEM instance with the DEV runmode, if you see the same behavior on your local, it is clear that something is wrong with your runmodes and configuration. Please check the below documentation to make sure you are embedding correctly the package;

 

https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/how-to-add-acs-aem-commons...

https://adobe-consulting-services.github.io/acs-aem-commons/pages/maven.html  

 



Esteban Bustamante

Avatar

Correct answer by
Level 3

I have tried the below command and it worked as expected also every time I got the Last Installed date and time for acs-aem-commons-ui-all,acs-aem-commons-ui.content and acs-aem-commons-ui.apps.

 

 

http://localhost:4502/crx/packmgr/service/.json/etc/packages/adobe/consulting/acs-aem-commons-all-6.0.14.zip -F recursive=true

 

Ref: https://github.com/Adobe-Consulting-Services/acs-aem-commons/issues/3228